Skip to content
Laskyr

Plugins · thim-blocks · data as of 2026-11-04

Is Thim Blocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.4)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.2 or newer fixes all of them that state a fix.

Latest version
1.0.4
Last updated
2026-08-22
Active installs
300+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Thim Blocks is a plugin which supports users to build theme with Gutenberg . — by ThimPress

What to do

  1. Update to the latest version (1.0.4). Anything older than 1.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get thim-blocks --field=version shows what you run; wp plugin update thim-blocks updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-13725 · published 2026-01-17

Path traversal / file read in Thim Blocks (1.0.1 and older)

Affected
1.0.1 and older
Fixed in
1.0.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gutenberg Thim Blocks – Page Builder, Gutenberg Blocks for the Block Editor plugin for WordPress is vulnerable to arbitrary file reads in all versions up to, and including, 1.0.1. This is due to insufficient path validation in the server-side rendering of the thim-blocks/icon block. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the contents of arbitrary files on the server via the 'iconSVG' parameter, which can contain sensitive information such as wp-config.php.

NVD CVE-2025-13725Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Thim Blocks vulnerability status badge
<a href="https://laskyr.com/plugins/thim-blocks"><img src="https://laskyr.com/plugins/thim-blocks/badge.svg" alt="Thim Blocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit