Skip to content
Laskyr

Plugins · themify-wc-product-filter · data as of 2026-11-04

Is Themify safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.9)

As of 2026-11-04. 4 issues are on record for older versions; version 1.5.6 or newer fixes all of them that state a fix.

Latest version
1.5.9
Last updated
2026-10-16
Active installs
20,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

This plugin helps shoppers quickly find products in your WooCommerce shop by filtering through price, categories, attributes, tags, and more. — by themifyme

What to do

  1. Update to the latest version (1.5.9). Anything older than 1.5.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get themify-wc-product-filter --field=version shows what you run; wp plugin update themify-wc-product-filter updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-78172 · published 2026-09-11

Reflected cross-site scripting (XSS) in Themify (1.5.5 and older)

Affected
1.5.5 and older
Fixed in
1.5.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Themify – WooCommerce Product Filter plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via Query Parameter Name in all versions up to, and including, 1.5.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2026-78172Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2024-44046 · published 2024-10-06

Stored cross-site scripting (XSS) in Themify (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in themifyme Themify – WooCommerce Product Filter themify-wc-product-filter allows Stored XSS.This issue affects Themify – WooCommerce Product Filter: from n/a through <= 1.5.1.

NVD CVE-2024-44046Patchstack advisory

high 7.5 CVE-2024-6027 · published 2024-06-21

SQL injection in Themify (1.4.9 and older)

Affected
1.4.9 and older
Fixed in
1.5.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Themify – WooCommerce Product Filter plugin for WordPress is vulnerable to time-based SQL Injection via the ‘conditions’ parameter in all versions up to, and including, 1.4.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-6027Wordfence advisoryCode change (fix)themify.orgPlugin source

medium 6.1 CVE-2022-1532 · published 2022-06-13

Reflected cross-site scripting (XSS) in Themify (older than 1.3.8)

Affected
older than 1.3.8
Fixed in
1.3.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

Themify WordPress plugin before 1.3.8 does not sanitise and escape the page parameter before outputting it back in an attribute in an admin page, leading to a Reflected Cross-Site Scripting

NVD CVE-2022-1532WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Themify vulnerability status badge
<a href="https://laskyr.com/plugins/themify-wc-product-filter"><img src="https://laskyr.com/plugins/themify-wc-product-filter/badge.svg" alt="Themify vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit