Plugins · themify-portfolio-post · data as of 2026-11-04
Is Themify Portfolio Post safe? Known vulnerabilities and latest version
- Latest version
- 1.3.3
- Last updated
- 2026-08-05
- Active installs
- 30,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.2+
Add a simple Portfolio post type to your site. — by themifyme
What to do
- Update to the latest version (1.3.3). Anything older than 1.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get themify-portfolio-post --field=version shows what you run; wp plugin update themify-portfolio-post updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2025-67533 · published 2025-12-09
Stored cross-site scripting (XSS) in Themify Portfolio Post (1.3.0 and older)
- Affected
- 1.3.0 and older
- Fixed in
- 1.3.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in themifyme Themify Portfolio Post themify-portfolio-post allows Stored XSS.This issue affects Themify Portfolio Post: from n/a through <= 1.3.0.
medium 5.4 CVE-2022-32970 · published 2023-05-10
Stored cross-site scripting (XSS) in Themify Portfolio Post (1.2.4 and older)
- Affected
- 1.2.4 and older
- Fixed in
- 1.2.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (editor+) Stored Cross-Site Scripting (XSS) vulnerability in Themify Themify Portfolio Post plugin <= 1.2.4 versions.
medium 5.4 CVE-2023-0362 · published 2023-02-13
Stored cross-site scripting (XSS) in Themify Portfolio Post (older than 1.2.2)
- Affected
- older than 1.2.2
- Fixed in
- 1.2.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Themify Portfolio Post WordPress plugin before 1.2.2 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
medium 5.4 CVE-2022-4464 · published 2023-01-16
Stored cross-site scripting (XSS) in Themify Portfolio Post (older than 1.2.1)
- Affected
- older than 1.2.1
- Fixed in
- 1.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Themify Portfolio Post WordPress plugin before 1.2.1 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks, which could be used against high privileged users such as admin.
medium 5.4 CVE-2022-0200 · published 2022-02-14
Reflected cross-site scripting (XSS) in Themify Portfolio Post (older than 1.1.7)
- Affected
- older than 1.1.7
- Fixed in
- 1.1.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
Themify Portfolio Post WordPress plugin before 1.1.7 does not sanitise and escape the num_of_pages parameter before outputting it back the response of the themify_create_popup_page_pagination AJAX action (available to any authenticated user), leading to a Reflected Cross-Site Scripting
medium 5.4 CVE-2021-24129 · published 2021-03-18
Stored cross-site scripting (XSS) in Themify Portfolio Post (older than 1.1.6)
- Affected
- older than 1.1.6
- Fixed in
- 1.1.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
Unvalidated input and lack of output encoding in the Themify Portfolio Post WordPress plugin, versions before 1.1.6, lead to Stored Cross-Site Scripting (XSS) vulnerabilities allowing low-privileged users (Contributor+) to inject arbitrary JavaScript code or HTML in posts where the Themify Custom Panel is embedded, which could lead to privilege escalation.
Recent activity
- 2026-08-05 — latest release on wordpress.org (1.3.3).
- 2025-12-09 — Stored cross-site scripting (XSS) disclosed (CVE-2025-67533), fixed in 1.3.1.
- 2023-05-10 — Stored cross-site scripting (XSS) disclosed (CVE-2022-32970), fixed in 1.2.5.
- 2023-02-13 — Stored cross-site scripting (XSS) disclosed (CVE-2023-0362), fixed in 1.2.2.
Get an email when Themify Portfolio Post has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Themify Portfolio Post (themify-portfolio-post) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by themifyme (6 tracked)
Types found in this plugin: Cross-site scripting (XSS) (6)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/themify-portfolio-post (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/themify-portfolio-post"><img src="https://laskyr.com/plugins/themify-portfolio-post/badge.svg" alt="Themify Portfolio Post vulnerability status"></a>