Skip to content
Laskyr

Plugins · themify-popup · data as of 2026-11-04

Is Themify Popup safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.9)

As of 2026-11-04. 3 issues are on record for older versions; version 1.4.8 or newer fixes all of them that state a fix.

Latest version
1.4.9
Last updated
2026-10-29
Active installs
8,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Turn visitors into subscribers and increase sale conversions! Use Popup to show newsletter forms, promotions, or lightbox content. — by themifyme

What to do

  1. Update to the latest version (1.4.9). Anything older than 1.4.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get themify-popup --field=version shows what you run; wp plugin update themify-popup updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-109989 · published 2026-10-17

Stored cross-site scripting (XSS) in Themify Popup (1.4.7 and older)

Affected
1.4.7 and older
Fixed in
1.4.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Themify Popup plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'popup_width_unit' parameter in all versions up to, and including, 1.4.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-109989Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2026-56037 · published 2026-07-02

PHP object injection in Themify Popup (1.4.3 and older)

Affected
1.4.3 and older
Fixed in
1.4.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Themify Themify Popup allows Object Injection. This issue affects Themify Popup: from n/a through 1.4.3.

NVD CVE-2026-56037Patchstack advisory

medium 6.5 CVE-2025-58787 · published 2025-09-05

Stored cross-site scripting (XSS) in Themify Popup (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.4.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in themifyme Themify Popup themify-popup allows Stored XSS.This issue affects Themify Popup: from n/a through <= 1.4.2.

NVD CVE-2025-58787Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Themify Popup vulnerability status badge
<a href="https://laskyr.com/plugins/themify-popup"><img src="https://laskyr.com/plugins/themify-popup/badge.svg" alt="Themify Popup vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit