Skip to content
Laskyr

Plugins · themify-event-post · data as of 2026-11-04

Is Themify Event Post safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.7)

As of 2026-11-04. 4 issues are on record for older versions; version 1.3.5 or newer fixes all of them that state a fix.

Latest version
1.3.7
Last updated
2026-08-05
Active installs
2,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.2+

This plugin will add Event post type. — by themifyme

What to do

  1. Update to the latest version (1.3.7). Anything older than 1.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get themify-event-post --field=version shows what you run; wp plugin update themify-event-post updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-32449 · published 2026-03-13

Stored cross-site scripting (XSS) in Themify Event Post (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in themifyme Themify Event Post themify-event-post allows Stored XSS.This issue affects Themify Event Post: from n/a through <= 1.3.4.

NVD CVE-2026-32449Patchstack advisory

high 7.5 CVE-2025-30831 · published 2025-03-27

File inclusion in Themify Event Post (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in themifyme Themify Event Post themify-event-post allows PHP Local File Inclusion.This issue affects Themify Event Post: from n/a through <= 1.3.2.

NVD CVE-2025-30831Patchstack advisory

medium 6.5 CVE-2025-30832 · published 2025-03-27

Cross-site scripting (XSS) in Themify Event Post (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in themifyme Themify Event Post themify-event-post allows DOM-Based XSS.This issue affects Themify Event Post: from n/a through <= 1.3.2.

NVD CVE-2025-30832Patchstack advisory

medium 5.9 CVE-2024-30440 · published 2024-03-29

Stored cross-site scripting (XSS) in Themify Event Post (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.2.8
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themify Themify Event Post allows Stored XSS.This issue affects Themify Event Post: from n/a through 1.2.7.

NVD CVE-2024-30440Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Themify Event Post vulnerability status badge
<a href="https://laskyr.com/plugins/themify-event-post"><img src="https://laskyr.com/plugins/themify-event-post/badge.svg" alt="Themify Event Post vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit