Skip to content
Laskyr

Plugins · themeruby-multi-authors · data as of 2026-11-04

Is ThemeRuby Multi Authors safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.1.0 or newer fixes all of them that state a fix.

Latest version
1.3.0
Last updated
2026-05-22
Active installs
2,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

A lightweight plugin that allows you to assign multiple writers to posts, fast and easy to use. — by ThemeRuby

What to do

  1. Update to the latest version (1.3.0). Anything older than 1.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get themeruby-multi-authors --field=version shows what you run; wp plugin update themeruby-multi-authors updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1097 · published 2026-01-24

Stored cross-site scripting (XSS) in ThemeRuby Multi Authors (1.0.0 and older)

Affected
1.0.0 and older
Fixed in
1.1.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ThemeRuby Multi Authors – Assign Multiple Writers to Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'before' and 'after' shortcode attributes in all versions up to, and including, 1.0.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1097Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ThemeRuby Multi Authors vulnerability status badge
<a href="https://laskyr.com/plugins/themeruby-multi-authors"><img src="https://laskyr.com/plugins/themeruby-multi-authors/badge.svg" alt="ThemeRuby Multi Authors vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit