Skip to content
Laskyr

Plugins · theme-my-login · data as of 2026-11-04

Is Theme My Login safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.3.1)

As of 2026-11-04. 7 issues are on record for older versions; version 7.2.2 or newer fixes all of them that state a fix.

Latest version
7.3.1
Last updated
2026-10-13
Active installs
50,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4

Frontend login, registration and password reset pages that match your theme, at your own URLs, instead of the default wp-login.php screen. — by Jeff Farthing

What to do

  1. Update to the latest version (7.3.1). Anything older than 7.2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get theme-my-login --field=version shows what you run; wp plugin update theme-my-login updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-89079 · published 2026-10-16

Privilege escalation in Theme My Login (7.2.1 and older)

Affected
7.2.1 and older
Fixed in
7.2.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Theme My Login plugin for WordPress is vulnerable to privilege escalation via account takeover in versions up to, and including, 7.2.1. This is due to the plugin not properly validating a user's identity prior to updating their password. This makes it possible for unauthenticated attackers to change arbitrary user's passwords on multi-site setups in certain configurations.

NVD CVE-2026-89079Wordfence advisoryCode change (fix)

medium 4.3 CVE-2026-83628 · published 2026-09-05

Missing authorization check in Theme My Login (7.1.15 and older)

Affected
7.1.15 and older
Fixed in
7.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Theme My Login plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 7.1.15 on Multisite installations. This is due to the `tml_ms_signup_handler()` function's `gimmeanotherblog` branch failing to enforce the network's `active_signup` registration policy, checking only `is_user_logged_in()` while sibling branches such as `validate-blog-signup` apply the full policy gate. This makes it possible for authenticated attackers, with Subscriber-level access and above, to directly POST `stage=gimmeanotherblog` to Theme My Login's signup route, bypassing the configured registration policy entirely — even when it is set to `none` or `user` — which causes `wpmu_create_blog()` to execute with the attacker's user ID, after which WordPress core assigns the Administrator role on the newly created subsite via `add_user_to_blog()`. The privilege gain is scoped to the newly created subsite only; the attacker's account retains Subscriber-level access on the main site and does not obtain Super Admin or network-level capabilities such as `manage_network` or `manage_sites`.

NVD CVE-2026-83628Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2026-81583 · published 2026-09-02

Privilege escalation in Theme My Login (7.0 up to (not including) 7.2.0)

Affected
7.0 up to (not including) 7.2.0
Fixed in
7.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The My Login WordPress plugin before 7.2.0 does not enforce the network's registration setting when processing site signups on multisite installations, allowing users with a subscriber account, and unauthenticated users on some networks, to create new sites and be granted administrator over them.

NVD CVE-2026-81583WPScan advisory

medium 4.3 CVE-2026-66681 · published 2026-08-06

Cross-site request forgery (CSRF) in Theme My Login (7.1.14 and older)

Affected
7.1.14 and older
Fixed in
7.1.15 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Theme My Login <= 7.1.14 versions.

NVD CVE-2026-66681Patchstack advisory

medium 6.5 CVE-2025-60098 · published 2025-09-26

Missing authorization check in Theme My Login (7.1.12 and older)

Affected
7.1.12 and older
Fixed in
7.1.13
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Jeff Farthing Theme My Login theme-my-login allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Theme My Login: from n/a through <= 7.1.12.

NVD CVE-2025-60098Patchstack advisory

medium 4.3 CVE-2024-7422 · published 2024-08-16

Cross-site request forgery (CSRF) in Theme My Login (7.1.7 and older)

Affected
7.1.7 and older
Fixed in
7.1.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Theme My Login plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 7.1.7. This is due to missing or incorrect nonce validation on the tml_admin_save_ms_settings() function. This makes it possible for unauthenticated attackers to update the theme's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please note that this only affects multi-site instances.

NVD CVE-2024-7422Wordfence advisoryCode change (fix)

medium 4.3 CVE-2024-32525 · published 2024-04-17

Missing authorization check in Theme My Login (7.1.6 and older)

Affected
7.1.6 and older
Fixed in
7.1.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Theme My Login.This issue affects Theme My Login: from n/a through 7.1.6.

NVD CVE-2024-32525Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Theme My Login vulnerability status badge
<a href="https://laskyr.com/plugins/theme-my-login"><img src="https://laskyr.com/plugins/theme-my-login/badge.svg" alt="Theme My Login vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit