Plugins · theatre · data as of 2026-11-04
Is Theater for WordPress safe? Known vulnerabilities and latest version
- Latest version
- 0.19.1
- Last updated
- 2025-12-17
- Active installs
- 600+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 5.4+
Manage and publish events for your theater, live venue, cinema, club or festival. — by Jeroen Schmit
What to do
- Update to the latest version (0.19.1). Anything older than 0.19.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get theatre --field=version shows what you run; wp plugin update theatre updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-69343 · published 2026-03-05
Stored cross-site scripting (XSS) in Theater for WordPress (0.19 and older)
- Affected
- 0.19 and older
- Fixed in
- 0.19.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jeroen Schmit Theater for WordPress theatre allows Stored XSS.This issue affects Theater for WordPress: from n/a through <= 0.19.
medium 4.3 CVE-2025-69331 · published 2026-01-06
Missing authorization check in Theater for WordPress (0.19 and older)
- Affected
- 0.19 and older
- Fixed in
- 0.19.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Jeroen Schmit Theater for WordPress theatre allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Theater for WordPress: from n/a through <= 0.19.
medium 5.3 CVE-2025-64259 · published 2025-11-13
Missing authorization check in Theater for WordPress (0.18.8 and older)
- Affected
- 0.18.8 and older
- Fixed in
- 0.19
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Jeroen Schmit Theater for WordPress theatre allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Theater for WordPress: from n/a through <= 0.18.8.
medium 6.5 CVE-2025-58020 · published 2025-09-22
Stored cross-site scripting (XSS) in Theater for WordPress (0.18.8 and older)
- Affected
- 0.18.8 and older
- Fixed in
- 0.19
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jeroen Schmit Theater for WordPress theatre allows Stored XSS.This issue affects Theater for WordPress: from n/a through <= 0.18.8.
medium 4.3 CVE-2025-31846 · published 2025-04-01
Missing authorization check in Theater for WordPress (0.18.7 and older)
- Affected
- 0.18.7 and older
- Fixed in
- 0.18.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Jeroen Schmit Theater for WordPress theatre allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Theater for WordPress: from n/a through <= 0.18.7.
medium 6.1 CVE-2024-11371 · published 2024-11-21
Reflected cross-site scripting (XSS) in Theater for WordPress (0.18.6.2 and older)
- Affected
- 0.18.6.2 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Theater for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 0.18.6.2. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-11371Wordfence advisoryCode change (fix)Plugin source
medium 4.8 CVE-2023-47833 · published 2023-11-23
Cross-site scripting (XSS) in Theater for WordPress (0.18.3 and older)
- Affected
- 0.18.3 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jeroen Schmit Theater for WordPress plugin <= 0.18.3 versions.
Recent activity
- 2025-12-17 — latest release on wordpress.org (0.19.1).
- 2026-03-05 — Stored cross-site scripting (XSS) disclosed (CVE-2025-69343), fixed in 0.19.1.
- 2026-01-06 — Missing authorization check disclosed (CVE-2025-69331), fixed in 0.19.1.
- 2025-11-13 — Missing authorization check disclosed (CVE-2025-64259), fixed in 0.19.
Get an email when Theater for WordPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Theater for WordPress (theatre) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/theatre (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/theatre"><img src="https://laskyr.com/plugins/theatre/badge.svg" alt="Theater for WordPress vulnerability status"></a>