Plugins · the-moneytizer · data as of 2026-11-04
Is The Moneytizer safe? Known vulnerabilities and latest version
- Latest version
- 10.0.10
- Last updated
- 2026-03-09
- Active installs
- 1,000+
- Known issues on record
- 5
- Unpatched in latest
- 1
- Tested up to WP
- 6.9.11 · PHP 7.0+
Monetize your website thanks to advertising. The « all in one » solution to make you earn money thanks to a wide range of ad formats. — by lvaudore
What to do
- There is no fixed version yet. If you can live without The Moneytizer for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get the-moneytizer --field=version shows what you run; wp plugin update the-moneytizer updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 affects latest 10.0.10 CVE-2026-39685 · published 2026-04-08
Missing authorization check in The Moneytizer (10.0.10 and older)
- Affected
- 10.0.10 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in lvaudore The Moneytizer the-moneytizer allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects The Moneytizer: from n/a through <= 10.0.10.
medium 6.5 CVE-2025-62756 · published 2025-12-31
Cross-site scripting (XSS) in The Moneytizer (10.0.9 and older)
- Affected
- 10.0.9 and older
- Fixed in
- 10.0.10
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in lvaudore The Moneytizer the-moneytizer allows DOM-Based XSS.This issue affects The Moneytizer: from n/a through <= 10.0.9.
high 8.1 CVE-2023-6966 · published 2024-06-06
Missing authorization check in The Moneytizer (9.6.3 and older)
- Affected
- 9.6.3 and older
- Fixed in
- 10.0.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The The Moneytizer plugin for WordPress is vulnerable to unauthorized access of data, modification of data, and loss of data due to a missing capability check on multiple AJAX functions in the /core/core_ajax.php file in all versions up to, and including, 9.6.3. This makes it possible for authenticated attackers, with subscriber access and above, to update and retrieve billing and bank details, update and reset the plugin's settings, and update languages as well as other lower-severity actions.
NVD CVE-2023-6966Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2023-6968 · published 2024-06-06
Cross-site request forgery (CSRF) in The Moneytizer (9.6.3 and older)
- Affected
- 9.6.3 and older
- Fixed in
- 10.0.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The The Moneytizer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 9.6.3. This is due to missing or incorrect nonce validation on multiple AJAX functions. This makes it possible for unauthenticated attackers to to update and retrieve billing and bank details, update and reset the plugin's settings, and update languages as well as other lower-severity actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2023-6968Wordfence advisoryCode change (fix)wordpress.org
medium 6.5 CVE-2024-27990 · published 2024-04-11
Stored cross-site scripting (XSS) in The Moneytizer (9.5.20 and older)
- Affected
- 9.5.20 and older
- Fixed in
- 9.6.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in The Moneytizer allows Stored XSS.This issue affects The Moneytizer: from n/a through 9.5.20.
Recent activity
- 2026-03-09 — latest release on wordpress.org (10.0.10).
- 2026-04-08 — Missing authorization check disclosed (CVE-2026-39685), no fix listed yet.
- 2025-12-31 — Cross-site scripting (XSS) disclosed (CVE-2025-62756), fixed in 10.0.10.
- 2024-06-06 — Missing authorization check disclosed (CVE-2023-6966), fixed in 10.0.1.
Get an email when The Moneytizer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for The Moneytizer (the-moneytizer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/the-moneytizer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/the-moneytizer"><img src="https://laskyr.com/plugins/the-moneytizer/badge.svg" alt="The Moneytizer vulnerability status"></a>