Skip to content
Laskyr

Plugins · the-events-calendar-shortcode · data as of 2026-11-04

Is The Events Calendar Shortcode & Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.0)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1.3 or newer fixes all of them that state a fix.

Latest version
4.0.0
Last updated
2026-08-18
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Add shortcode, block and Elementor widget functionality to The Events Calendar Plugin, so you can easily list and promote your events anywhere. — by Event Calendar Newsletter

What to do

  1. Update to the latest version (4.0.0). Anything older than 3.1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get the-events-calendar-shortcode --field=version shows what you run; wp plugin update the-events-calendar-shortcode updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1922 · published 2026-02-10

Stored cross-site scripting (XSS) in The Events Calendar Shortcode & Block (3.1.2 and older)

Affected
3.1.2 and older
Fixed in
3.1.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The Events Calendar Shortcode & Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `ecs-list-events` shortcode `message` attribute in all versions up to, and including, 3.1.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1922Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-24988 · published 2026-02-03

Stored cross-site scripting (XSS) in The Events Calendar Shortcode & Block (3.1.1 and older)

Affected
3.1.1 and older
Fixed in
3.1.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brian Hogg The Events Calendar Shortcode & Block the-events-calendar-shortcode allows Stored XSS.This issue affects The Events Calendar Shortcode & Block: from n/a through <= 3.1.1.

NVD CVE-2026-24988Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
The Events Calendar Shortcode & Block vulnerability status badge
<a href="https://laskyr.com/plugins/the-events-calendar-shortcode"><img src="https://laskyr.com/plugins/the-events-calendar-shortcode/badge.svg" alt="The Events Calendar Shortcode & Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit