Skip to content
Laskyr

Plugins · the-cache-purger · data as of 2026-11-04

Is The Cache Purger safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.59)

As of 2026-11-04. 1 issue is on record for older versions; version 2.3.21 or newer fixes all of them that state a fix.

Latest version
2.3.59
Last updated
2026-09-02
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Automatically purge every server-side cache on your WordPress site — plugins, hosting environments, PHP, memory stores, and CDNs — all from one place. — by Kevin Pirnie

What to do

  1. Update to the latest version (2.3.59). Anything older than 2.3.21 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get the-cache-purger --field=version shows what you run; wp plugin update the-cache-purger updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-15350 · published 2026-07-16

Missing authorization check in The Cache Purger (2.3.20 and older)

Affected
2.3.20 and older
Fixed in
2.3.21 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The The Cache Purger plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.3.20. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to permanently truncate the plugin's cache-purge audit log (wp-content/purge.log), destroying the entire cache-purge audit history. The tcp_log_purge nonce is rendered in the admin bar on frontend pages accessible to all authenticated users including subscribers, meaning any authenticated user possesses the nonce required to trigger the deletion.

NVD CVE-2026-15350Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
The Cache Purger vulnerability status badge
<a href="https://laskyr.com/plugins/the-cache-purger"><img src="https://laskyr.com/plugins/the-cache-purger/badge.svg" alt="The Cache Purger vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit