Skip to content
Laskyr

Plugins · thai-lottery-widget · data as of 2026-11-04

Is Thai Lottery Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6)

As of 2026-11-04. 1 issue is on record for older versions; version 2.6 or newer fixes all of them that state a fix.

Latest version
2.6
Last updated
2026-04-17
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.6+

แสดงผลสลากกินแบ่งรัฐบาลไทย โค้ดตรวจหวย — by Siam ลอตเตอรี่

What to do

  1. Update to the latest version (2.6). Anything older than 2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get thai-lottery-widget --field=version shows what you run; wp plugin update thai-lottery-widget updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-13678 · published 2025-12-05

Stored cross-site scripting (XSS) in Thai Lottery Widget (2.5 and older)

Affected
2.5 and older
Fixed in
2.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Thai Lottery Widget plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `thailottery` shortcode in all versions up to, and including, 2.5. This is due to insufficient input sanitization and output escaping on the user supplied `width` and `height` shortcode attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13678Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Thai Lottery Widget vulnerability status badge
<a href="https://laskyr.com/plugins/thai-lottery-widget"><img src="https://laskyr.com/plugins/thai-lottery-widget/badge.svg" alt="Thai Lottery Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit