Skip to content
Laskyr

Plugins · th-advance-product-search · data as of 2026-11-04

Is Advance Product Search- Voice & Ajax Search fo… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.0)

As of 2026-11-04. 5 issues are on record for older versions; version 1.4.9 or newer fixes all of them that state a fix.

Latest version
1.5.0
Last updated
2026-10-17
Active installs
9,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Advanced Product Search boosts your store search with instant AJAX results, live suggestions helping customers find products faster. — by ThemeHunk

What to do

  1. Update to the latest version (1.5.0). Anything older than 1.4.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get th-advance-product-search --field=version shows what you run; wp plugin update th-advance-product-search updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-66607 · published 2026-08-20

Cross-site scripting (XSS) in Advance Product Search- Voice & Ajax Search fo… (1.4.8 and older)

Affected
1.4.8 and older
Fixed in
1.4.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Advance Product Search <= 1.4.8 versions.

NVD CVE-2026-66607Patchstack advisory

high 7.5 CVE-2026-12753 · published 2026-07-16

SQL injection in Advance Product Search- Voice & Ajax Search fo… (1.4.4 and older)

Affected
1.4.4 and older
Fixed in
1.4.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Advance Product Search- Voice & Ajax Search for WooCommerce plugin for WordPress is vulnerable to generic SQL Injection via the 's' and 'match' parameter in all versions up to, and including, 1.4.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-12753Wordfence advisoryCode change (fix)Plugin source

critical 9.3 CVE-2026-56070 · published 2026-06-26

SQL injection in Advance Product Search- Voice & Ajax Search fo… (1.4.4 and older)

Affected
1.4.4 and older
Fixed in
1.4.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in Advance Product Search <= 1.4.4 versions.

NVD CVE-2026-56070Patchstack advisory

critical 9.8 CVE-2022-40218 · published 2024-05-08

Missing authorization check in Advance Product Search- Voice & Ajax Search fo… (1.1.4 and older)

Affected
1.1.4 and older
Fixed in
1.1.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in ThemeHunk Advance WordPress Search Plugin.This issue affects Advance WordPress Search Plugin: from n/a through 1.1.4.

NVD CVE-2022-40218Patchstack advisory

critical 9.8 CVE-2022-38057 · published 2024-03-25

Missing authorization check in Advance Product Search- Voice & Ajax Search fo… (1.2.1 and older)

Affected
1.2.1 and older
Fixed in
1.2.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in ThemeHunk Advance WordPress Search Plugin.This issue affects Advance WordPress Search Plugin: from n/a through 1.2.1.

NVD CVE-2022-38057Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Advance Product Search- Voice & Ajax Search fo… vulnerability status badge
<a href="https://laskyr.com/plugins/th-advance-product-search"><img src="https://laskyr.com/plugins/th-advance-product-search/badge.svg" alt="Advance Product Search- Voice & Ajax Search fo… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit