Skip to content
Laskyr

Plugins · textp2p-texting-widget · data as of 2026-11-04

Is TextP2P Texting Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1)

As of 2026-11-04. 1 issue is on record for older versions.

Latest version
2.1
Last updated
2026-10-26
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8

Allow site visitors to contact your business the way most prefer, by Texting. Installing the TextP2P Texting Widget plugin into your WordPress site pr … — by Greg Armfield

What to do

  1. Update to the latest version (2.1). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get textp2p-texting-widget --field=version shows what you run; wp plugin update textp2p-texting-widget updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-4133 · published 2026-04-22

Cross-site request forgery (CSRF) in TextP2P Texting Widget (1.7 and older)

Affected
1.7 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The TextP2P Texting Widget plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to and including 1.7. This is due to missing nonce validation in the imTextP2POptionPage() function which processes settings updates. The form at line 314 does not include a wp_nonce_field(), and the POST handler at line 7 does not call check_admin_referer() or wp_verify_nonce() before processing settings changes. This makes it possible for unauthenticated attackers to update all plugin settings including chat widget titles, messages, API credentials, colors, and reCAPTCHA configuration via a forged request, granted they can trick a site administrator into performing an action such as clicking a link.

NVD CVE-2026-4133Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
TextP2P Texting Widget vulnerability status badge
<a href="https://laskyr.com/plugins/textp2p-texting-widget"><img src="https://laskyr.com/plugins/textp2p-texting-widget/badge.svg" alt="TextP2P Texting Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit