Skip to content
Laskyr

Plugins · text-to-speech-tts · data as of 2026-11-04

Is Text to Speech safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.40)

As of 2026-11-04. 1 issue is on record for older versions; version 1.9.9 or newer fixes all of them that state a fix.

Latest version
3.3.40
Last updated
2026-10-30
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Text to speech for WordPress with natural ElevenLabs AI voices, an accessible audio player, and 10,000 free credits to start. — by Norse Digital Group LLC

What to do

  1. Update to the latest version (3.3.40). Anything older than 1.9.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get text-to-speech-tts --field=version shows what you run; wp plugin update text-to-speech-tts updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-1233 · published 2026-04-04

Information disclosure in Text to Speech (1.9.8 and older)

Affected
1.9.8 and older
Fixed in
1.9.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Text to Speech for WP (AI Voices by Mementor) plugin for WordPress is vulnerable to sensitive information exposure in all versions up to, and including, 1.9.8. This is due to the plugin containing hardcoded MySQL database credentials for the vendor's external telemetry server in the `Mementor_TTS_Remote_Telemetry` class. This makes it possible for unauthenticated attackers to extract and decode these credentials, gaining unauthorized write access to the vendor's telemetry database.

NVD CVE-2026-1233Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Text to Speech vulnerability status badge
<a href="https://laskyr.com/plugins/text-to-speech-tts"><img src="https://laskyr.com/plugins/text-to-speech-tts/badge.svg" alt="Text to Speech vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit