Skip to content
Laskyr

Plugins · templatespare · data as of 2026-11-04

Is TemplateSpare safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.4.0)

As of 2026-11-04. 3 issues are on record for older versions; version 4.2.1 or newer fixes all of them that state a fix.

Latest version
4.4.0
Last updated
2026-11-03
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

1000+ news, magazine & blog starter templates, 1-click demo importer & site migration tool by AF Themes for Elementor, Gutenberg & WooCommerce. — by Templatespare

What to do

  1. Update to the latest version (4.4.0). Anything older than 4.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get templatespare --field=version shows what you run; wp plugin update templatespare updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-65530 · published 2026-07-23

Missing authorization check in TemplateSpare (4.2.2 and older)

Affected
4.2.2 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in TemplateSpare <= 4.2.2 versions.

NVD CVE-2026-65530Patchstack advisory

critical 9.1 CVE-2026-57658 · published 2026-06-26

Arbitrary file upload in TemplateSpare (4.2.0 and older)

Affected
4.2.0 and older
Fixed in
4.2.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Administrator Arbitrary File Upload in TemplateSpare <= 4.2.0 versions.

NVD CVE-2026-57658Patchstack advisory

medium 5.4 CVE-2024-6872 · published 2024-08-03

Missing authorization check in TemplateSpare (2.4.2 and older)

Affected
2.4.2 and older
Fixed in
4.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Build Your Dream Website Fast with 400+ Starter Templates and Landing Pages, No Coding Needed, One-Click Import for Elementor & Gutenberg Blocks! – TemplateSpare plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'templatespare_activate_required_theme' and 'templatespare_get_theme_status' functions in all versions up to, and including, 2.4.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to activate any installed theme and read any theme status. If the attacker attempts to activate a theme that is not installed, a non-existent theme with the slug chosen by the attacker will be considered the active theme, leaving the site with no theme functionality.

NVD CVE-2024-6872Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
TemplateSpare vulnerability status badge
<a href="https://laskyr.com/plugins/templatespare"><img src="https://laskyr.com/plugins/templatespare/badge.svg" alt="TemplateSpare vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit