Skip to content
Laskyr

Plugins · template-kit-import · data as of 2026-11-01

Is Template Kit safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.17)

As of 2026-11-01. 2 issues are on record for older versions; version 1.0.17 or newer fixes all of them that state a fix.

Latest version
1.0.17
Last updated
2026-09-17
Active installs
400,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.4.14 · PHP 8.3+

Use this plugin to import Template Kits to WordPress — by envato

What to do

  1. Update to the latest version (1.0.17). Anything older than 1.0.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get template-kit-import --field=version shows what you run; wp plugin update template-kit-import updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.8 CVE-2026-96824 · published 2026-09-30

Arbitrary file deletion in Template Kit (1.0.16 and older)

Affected
1.0.16 and older
Fixed in
1.0.17
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Editor Arbitrary File Deletion in Template Kit – Import <= 1.0.16 versions.

NVD CVE-2026-96824Patchstack advisory

medium 6.4 CVE-2024-2334 · published 2024-04-09

Stored cross-site scripting (XSS) in Template Kit (1.0.14 and older)

Affected
1.0.14 and older
Fixed in
1.0.15 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Template Kit – Import plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the template upload functionality in all versions up to, and including, 1.0.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2334Wordfence advisoryCode change (fix)Plugin source

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Template Kit vulnerability status badge
<a href="https://laskyr.com/plugins/template-kit-import"><img src="https://laskyr.com/plugins/template-kit-import/badge.svg" alt="Template Kit vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit