Skip to content
Laskyr

Plugins · telsender · data as of 2026-11-04

Is TelSender safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.14.15)

As of 2026-11-04. 2 issues are on record for older versions; version 1.14.15 or newer fixes all of them that state a fix.

Latest version
1.14.15
Last updated
2026-01-29
Active installs
5,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

TelSender - a plugin that works with contact form 7 and the woocommerce store in wordpress. It sends applications from forms to a chat telegram. — by pechenki

What to do

  1. Update to the latest version (1.14.15). Anything older than 1.14.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get telsender --field=version shows what you run; wp plugin update telsender updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-15298 · published 2026-07-10

DOM-based cross-site scripting (XSS) in TelSender (1.14.14 and older)

Affected
1.14.14 and older
Fixed in
1.14.15 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The TelSender plugin for WordPress is vulnerable to DOM-Based Cross-Site Scripting in all versions up to, and including, 1.14.14. This is due to insufficient input sanitization when processing Telegram API responses containing attacker-controlled chat titles. This makes it possible for unauthenticated attackers to inject malicious scripts via Telegram chat titles that execute when an administrator opens the TelSender settings page and clicks the "Tested" button.

NVD CVE-2026-15298Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-41683 · published 2024-12-13

Missing authorization check in TelSender (1.14.11 and older)

Affected
1.14.11 and older
Fixed in
1.14.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Pechenki TelSender allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects TelSender: from n/a through 1.14.11.

NVD CVE-2023-41683Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
TelSender vulnerability status badge
<a href="https://laskyr.com/plugins/telsender"><img src="https://laskyr.com/plugins/telsender/badge.svg" alt="TelSender vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit