Plugins · telegram-bot · data as of 2026-11-04
Is Telegram Bot & Channel safe? Known vulnerabilities and latest version
- Latest version
- 4.2.1
- Last updated
- 2026-10-14
- Active installs
- 500+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.2 · PHP 7.0+
Broadcast posts to Telegram channels, groups and subscribers, and build interactive bots with autoresponders, keyboards and Zapier. — by Marco Milesi
What to do
- Update to the latest version (4.2.1). Anything older than 4.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get telegram-bot --field=version shows what you run; wp plugin update telegram-bot updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2025-13068 · published 2025-11-25
Stored cross-site scripting (XSS) in Telegram Bot & Channel (4.1 and older)
- Affected
- 4.1 and older
- Fixed in
- 4.1.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Telegram Bot & Channel plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Telegram username in all versions up to, and including, 4.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 5.4 CVE-2024-38789 · published 2025-01-02
Cross-site request forgery (CSRF) in Telegram Bot & Channel (3.8.2 and older)
- Affected
- 3.8.2 and older
- Fixed in
- 4.0.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Marco Milesi Telegram Bot & Channel telegram-bot allows Cross Site Request Forgery.This issue affects Telegram Bot & Channel: from n/a through <= 3.8.2.
medium 4.8 CVE-2023-34006 · published 2023-06-22
Stored cross-site scripting (XSS) in Telegram Bot & Channel (3.6.2 and older)
- Affected
- 3.6.2 and older
- Fixed in
- 3.6.3
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Marco Milesi Telegram Bot & Channel plugin <= 3.6.2 versions.
Recent activity
- 2026-10-14 — latest release on wordpress.org (4.2.1).
- 2025-11-25 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13068), fixed in 4.1.1.
- 2025-01-02 — Cross-site request forgery (CSRF) disclosed (CVE-2024-38789), fixed in 4.0.1.
- 2023-06-22 — Stored cross-site scripting (XSS) disclosed (CVE-2023-34006), fixed in 3.6.3.
Get an email when Telegram Bot & Channel has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Telegram Bot & Channel (telegram-bot) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Marco Milesi (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/telegram-bot (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/telegram-bot"><img src="https://laskyr.com/plugins/telegram-bot/badge.svg" alt="Telegram Bot & Channel vulnerability status"></a>