Skip to content
Laskyr

Plugins · team-showcase · data as of 2026-11-04

Is Team Showcase safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.1)

As of 2026-11-04. 2 issues are on record for older versions; version 3.0.0 or newer fixes all of them that state a fix.

Latest version
3.0.1
Last updated
2026-08-31
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

Create beautiful, responsive team member sections with grid, slider, list, popup, and carousel layouts. Perfect for companies, agencies, startups, sch … — by Themepoints

What to do

  1. Update to the latest version (3.0.1). Anything older than 3.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get team-showcase --field=version shows what you run; wp plugin update team-showcase updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-69335 · published 2026-01-06

Stored cross-site scripting (XSS) in Team Showcase (2.9 and older)

Affected
2.9 and older
Fixed in
3.0.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Themepoints Team Showcase team-showcase allows Stored XSS.This issue affects Team Showcase: from n/a through <= 2.9.

NVD CVE-2025-69335Patchstack advisory

medium 5.4 CVE-2023-5639 · published 2023-10-19

Stored cross-site scripting (XSS) in Team Showcase (2.1 and older)

Affected
2.1 and older
Fixed in
2.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Team Showcase plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'tmfshortcode' shortcode in all versions up to, and including, 2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-5639Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Team Showcase vulnerability status badge
<a href="https://laskyr.com/plugins/team-showcase"><img src="https://laskyr.com/plugins/team-showcase/badge.svg" alt="Team Showcase vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit