Skip to content
Laskyr

Plugins · team-section · data as of 2026-11-04

Is Team Section Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.5)

As of 2026-11-04. 3 issues are on record for older versions; version 2.0.5 or newer fixes all of them that state a fix.

Latest version
2.0.5
Last updated
2026-10-26
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Showcase your team members in various layouts and designs. — by bPlugins

What to do

  1. Update to the latest version (2.0.5). Anything older than 2.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get team-section --field=version shows what you run; wp plugin update team-section updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-62027 · published 2026-10-10

Cross-site scripting (XSS) in Team Section Block (2.0.4 and older)

Affected
2.0.4 and older
Fixed in
2.0.5 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Team Section Block <= 2.0.4 versions.

NVD CVE-2026-62027Patchstack advisory

medium 6.4 CVE-2026-0833 · published 2026-01-17

Stored cross-site scripting (XSS) in Team Section Block (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Team Section Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's block in all versions up to, and including, 2.0.0 due to insufficient input sanitization and output escaping on user-supplied social network link URLs. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0833Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-26949 · published 2025-02-25

Stored cross-site scripting (XSS) in Team Section Block (1.0.9 and older)

Affected
1.0.9 and older
Fixed in
1.1.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Team Section Block team-section allows Stored XSS.This issue affects Team Section Block: from n/a through <= 1.0.9.

NVD CVE-2025-26949Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Team Section Block vulnerability status badge
<a href="https://laskyr.com/plugins/team-section"><img src="https://laskyr.com/plugins/team-section/badge.svg" alt="Team Section Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit