Plugins · team · data as of 2026-11-04
Is Team Showcase safe? Known vulnerabilities and latest version
- Latest version
- 1.22.28
- Last updated
- 2026-06-08
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8
Fully responsive and mobile ready meet the team showcase plugin for wordpress. — by PickPlugins
What to do
- There is no fixed version yet. If you can live without Team Showcase for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get team --field=version shows what you run; wp plugin update team updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 1.22.28 CVE-2025-62745 · published 2026-05-25
Stored cross-site scripting (XSS) in Team Showcase (1.22.28 and older)
- Affected
- 1.22.28 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PickPlugins Team Showcase allows Stored XSS. This issue affects Team Showcase: from n/a through 1.22.28.
medium 6.1 CVE-2024-44002 · published 2024-09-18
Reflected cross-site scripting (XSS) in Team Showcase (1.22.25 and older)
- Affected
- 1.22.25 and older
- Fixed in
- 1.22.26
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PickPlugins Team Showcase team allows Reflected XSS.This issue affects Team Showcase: from n/a through <= 1.22.25.
medium 6.5 CVE-2024-43321 · published 2024-08-18
Stored cross-site scripting (XSS) in Team Showcase (1.22.23 and older)
- Affected
- 1.22.23 and older
- Fixed in
- 1.22.24
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in PickPlugins Team Showcase allows Stored XSS.This issue affects Team Showcase: from n/a through 1.22.23.
Recent activity
- 2026-06-08 — latest release on wordpress.org (1.22.28).
- 2026-05-25 — Stored cross-site scripting (XSS) disclosed (CVE-2025-62745), no fix listed yet.
- 2024-09-18 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-44002), fixed in 1.22.26.
- 2024-08-18 — Stored cross-site scripting (XSS) disclosed (CVE-2024-43321), fixed in 1.22.24.
Get an email when Team Showcase has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Team Showcase (team) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by PickPlugins (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/team (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/team"><img src="https://laskyr.com/plugins/team/badge.svg" alt="Team Showcase vulnerability status"></a>