Skip to content
Laskyr

Plugins · teachpress · data as of 2026-11-04

Is teachPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (9.0.13)

As of 2026-11-04. 10 issues are on record for older versions; version 9.0.13 or newer fixes all of them that state a fix.

Latest version
9.0.13
Last updated
2026-04-11
Active installs
2,000+
Known issues on record
10
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Manage your publications with teachPress — by winkm89

What to do

  1. Update to the latest version (9.0.13). Anything older than 9.0.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get teachpress --field=version shows what you run; wp plugin update teachpress updates it.

Check your version

Known vulnerabilities

10 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-22483 · published 2026-01-22

Cross-site request forgery (CSRF) in teachPress (9.0.12 and older)

Affected
9.0.12 and older
Fixed in
9.0.13 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in winkm89 teachPress teachpress allows Cross Site Request Forgery.This issue affects teachPress: from n/a through <= 9.0.12.

NVD CVE-2026-22483Patchstack advisory

medium 6.5 CVE-2026-22353 · published 2026-01-22

Stored cross-site scripting (XSS) in teachPress (9.0.12 and older)

Affected
9.0.12 and older
Fixed in
9.0.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in winkm89 teachPress teachpress allows Stored XSS.This issue affects teachPress: from n/a through <= 9.0.12.

NVD CVE-2026-22353Patchstack advisory

high 8.8 CVE-2025-32149 · published 2025-04-04

SQL injection in teachPress (9.0.11 and older)

Affected
9.0.11 and older
Fixed in
9.0.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in winkm89 teachPress teachpress allows SQL Injection.This issue affects teachPress: from n/a through <= 9.0.11.

NVD CVE-2025-32149Patchstack advisory

medium 4.3 CVE-2025-1320 · published 2025-03-25

Cross-site request forgery (CSRF) in teachPress (9.0.9 and older)

Affected
9.0.9 and older
Fixed in
9.0.11 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The teachPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 9.0.9. This is due to missing or incorrect nonce validation on the import.php page. This makes it possible for unauthenticated attackers to delete imports via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-1320Wordfence advisoryCode change (fix)wordpress.org

high 8.8 CVE-2025-1321 · published 2025-03-04

SQL injection in teachPress (9.0.7 and older)

Affected
9.0.7 and older
Fixed in
9.0.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The teachPress plugin for WordPress is vulnerable to SQL Injection via the 'order' parameter of the 'tpsearch' shortcode in all versions up to, and including, 9.0.7 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-1321Wordfence advisoryCode change (fix)

high 8.8 CVE-2023-52129 · published 2024-01-05

Cross-site request forgery (CSRF) in teachPress (9.0.4 and older)

Affected
9.0.4 and older
Fixed in
9.0.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Michael Winkler teachPress.This issue affects teachPress: from n/a through 9.0.4.

NVD CVE-2023-52129Patchstack advisory

high 8.8 CVE-2023-49163 · published 2023-12-18

Cross-site request forgery (CSRF) in teachPress (9.0.5 and older)

Affected
9.0.5 and older
Fixed in
9.0.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Michael Winkler teachPress.This issue affects teachPress: from n/a through 9.0.5.

NVD CVE-2023-49163Patchstack advisory

high 8.8 CVE-2023-48755 · published 2023-12-18

Cross-site request forgery (CSRF) in teachPress (9.0.4 and older)

Affected
9.0.4 and older
Fixed in
9.0.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Michael Winkler teachPress.This issue affects teachPress: from n/a through 9.0.4.

NVD CVE-2023-48755Patchstack advisory

medium 6.1 CVE-2023-36501 · published 2023-07-25

Reflected cross-site scripting (XSS) in teachPress (9.0.2 and older)

Affected
9.0.2 and older
Fixed in
9.0.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Michael Winkler teachPress plugin <= 9.0.2 versions.

NVD CVE-2023-36501Patchstack advisory

medium 6.1 CVE-2023-22704 · published 2023-03-23

Reflected cross-site scripting (XSS) in teachPress (8.1.8 and older)

Affected
8.1.8 and older
Fixed in
8.1.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Reflected Cross-Site Scripting (XSS) vulnerability in Michael Winkler teachPress plugin <= 8.1.8 versions.

NVD CVE-2023-22704Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
teachPress vulnerability status badge
<a href="https://laskyr.com/plugins/teachpress"><img src="https://laskyr.com/plugins/teachpress/badge.svg" alt="teachPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit