Plugins · tasty-recipes-lite · data as of 2026-11-04
Is Tasty Recipes Lite safe? Known vulnerabilities and latest version
- Latest version
- 1.2.11
- Last updated
- 2026-10-13
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
The WordPress recipe plugin food bloggers and recipe creators love. Schema comes baked in, so Google shows off your recipes! — by Strategy11 Team
What to do
- Update to the latest version (1.2.11). Anything older than 1.2.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get tasty-recipes-lite --field=version shows what you run; wp plugin update tasty-recipes-lite updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-110026 · published 2026-10-18
Missing authorization check in Tasty Recipes Lite (1.2 up to (not including) 1.2.11)
- Affected
- 1.2 up to (not including) 1.2.11
- Fixed in
- 1.2.11
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Tasty Recipes Lite WordPress plugin before 1.2.11 does not correctly check user capabilities when creating, renaming and deleting taxonomy terms, allowing users with a role as low as Contributor to add, rename and permanently delete terms in any taxonomy on the site, including categories, tags and navigation menus.
medium 4.3 CVE-2025-62131 · published 2025-12-31
Missing authorization check in Tasty Recipes Lite (1.1.5 and older)
- Affected
- 1.1.5 and older
- Fixed in
- 1.1.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Strategy11 Team Tasty Recipes Lite tasty-recipes-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Tasty Recipes Lite: from n/a through <= 1.1.5.
medium 4.3 CVE-2025-62132 · published 2025-12-31
Missing authorization check in Tasty Recipes Lite (1.1.5 and older)
- Affected
- 1.1.5 and older
- Fixed in
- 1.1.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Strategy11 Team Tasty Recipes Lite tasty-recipes-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Tasty Recipes Lite: from n/a through <= 1.1.5.
Recent activity
- 2026-10-13 — latest release on wordpress.org (1.2.11).
- 2026-10-18 — Missing authorization check disclosed (CVE-2026-110026), fixed in 1.2.11.
- 2025-12-31 — Missing authorization check disclosed (CVE-2025-62131), fixed in 1.1.6.
- 2025-12-31 — Missing authorization check disclosed (CVE-2025-62132), fixed in 1.1.6.
Get an email when Tasty Recipes Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Tasty Recipes Lite (tasty-recipes-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Strategy11 Team (4 tracked)
Types found in this plugin: Missing authorization (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/tasty-recipes-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/tasty-recipes-lite"><img src="https://laskyr.com/plugins/tasty-recipes-lite/badge.svg" alt="Tasty Recipes Lite vulnerability status"></a>