Skip to content
Laskyr

Plugins · taqnix · data as of 2026-11-04

Is Taqnix safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.4)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.4 or newer fixes all of them that state a fix.

Latest version
1.0.4
Last updated
2026-03-25
Active installs
30+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.7.11 · PHP 7.4+

Build AI-powered mobile apps for WordPress/WooCommerce. No code, 100+ templates, push alerts, payments. Launch in minutes. — by taqnix

What to do

  1. Update to the latest version (1.0.4). Anything older than 1.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get taqnix --field=version shows what you run; wp plugin update taqnix updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-3565 · published 2026-04-24

Cross-site request forgery (CSRF) in Taqnix (1.0.3 and older)

Affected
1.0.3 and older
Fixed in
1.0.4 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Taqnix plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.3. This is due to a missing nonce verification in the taqnix_delete_my_account() function, where the check_ajax_referer() call is explicitly commented out on line 883. This makes it possible for unauthenticated attackers to trick a logged-in non-administrator user into deleting their own account via a forged request granted they can trick the user into performing an action such as clicking a link or visiting a malicious page.

NVD CVE-2026-3565Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Taqnix vulnerability status badge
<a href="https://laskyr.com/plugins/taqnix"><img src="https://laskyr.com/plugins/taqnix/badge.svg" alt="Taqnix vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit