Skip to content
Laskyr

Plugins · tangible-loops-and-logic · data as of 2026-11-04

Is Tangible safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.3.3)

As of 2026-11-04. 3 issues are on record for older versions; version 4.3.0 or newer fixes all of them that state a fix.

Latest version
4.3.3
Last updated
2026-10-07
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Loops & Logic is a template system with content loops and conditions. — by Tangible

What to do

  1. Update to the latest version (4.3.3). Anything older than 4.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get tangible-loops-and-logic --field=version shows what you run; wp plugin update tangible-loops-and-logic updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-95604 · published 2026-09-23

Missing authorization check in Tangible (4.2.4 and older)

Affected
4.2.4 and older
Fixed in
4.3.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Loops & Logic <= 4.2.4 versions.

NVD CVE-2026-95604Patchstack advisory

medium 6.5 CVE-2026-57391 · published 2026-07-13

Stored cross-site scripting (XSS) in Tangible (4.2.3 and older)

Affected
4.2.3 and older
Fixed in
4.2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Tangible Loops & Logic tangible-loops-and-logic allows Stored XSS.This issue affects Loops & Logic: from n/a through <= 4.2.3.

NVD CVE-2026-57391Patchstack advisory

high 7.1 CVE-2024-47333 · published 2024-10-06

Reflected cross-site scripting (XSS) in Tangible (4.1.4 and older)

Affected
4.1.4 and older
Fixed in
4.1.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Tangible Loops & Logic tangible-loops-and-logic allows Reflected XSS.This issue affects Loops & Logic: from n/a through <= 4.1.4.

NVD CVE-2024-47333Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Tangible vulnerability status badge
<a href="https://laskyr.com/plugins/tangible-loops-and-logic"><img src="https://laskyr.com/plugins/tangible-loops-and-logic/badge.svg" alt="Tangible vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit