Plugins · tailored-tools · data as of 2026-11-04
Is Tailored Tools safe? Known vulnerabilities and latest version
- Latest version
- 3.0.5
- Last updated
- 2026-10-20
- Active installs
- 70+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Contains some helper classes to help you build custom forms. — by Tailored Media
What to do
- Update to the latest version (3.0.5). Anything older than 3.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get tailored-tools --field=version shows what you run; wp plugin update tailored-tools updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-111401 · published 2026-10-21
Cross-site request forgery (CSRF) in Tailored Tools (3.0.3 and older)
- Affected
- 3.0.3 and older
- Fixed in
- 3.0.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Tailored Media Tailored Tools tailored-tools allows Cross Site Request Forgery.This issue affects Tailored Tools: from n/a through 3.0.3.
critical 9.0 CVE-2026-62025 · published 2026-10-10
Arbitrary file upload in Tailored Tools (3.0.3 and older)
- Affected
- 3.0.3 and older
- Fixed in
- 3.0.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Arbitrary File Upload in Tailored Tools <= 3.0.3 versions.
high 7.1 CVE-2026-81765 · published 2026-08-31
Cross-site scripting (XSS) in Tailored Tools (3.0.2 and older)
- Affected
- 3.0.2 and older
- Fixed in
- 3.0.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Tailored Tools <= 3.0.2 versions.
medium 6.5 CVE-2024-52503 · published 2024-12-02
Stored cross-site scripting (XSS) in Tailored Tools (1.8.4 and older)
- Affected
- 1.8.4 and older
- Fixed in
- 3.0.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Tailored Media Tailored Tools tailored-tools allows Stored XSS.This issue affects Tailored Tools: from n/a through <= 1.8.4.
Recent activity
- 2026-10-20 — latest release on wordpress.org (3.0.5).
- 2026-10-21 — Cross-site request forgery (CSRF) disclosed (CVE-2026-111401), fixed in 3.0.5.
- 2026-10-10 — Arbitrary file upload disclosed (CVE-2026-62025), fixed in 3.0.5.
- 2026-08-31 — Cross-site scripting (XSS) disclosed (CVE-2026-81765), fixed in 3.0.3.
Get an email when Tailored Tools has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Tailored Tools (tailored-tools) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/tailored-tools (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/tailored-tools"><img src="https://laskyr.com/plugins/tailored-tools/badge.svg" alt="Tailored Tools vulnerability status"></a>