Plugins · tagembed-widget · data as of 2026-11-04
Is Tagembed safe? Known vulnerabilities and latest version
- Latest version
- 8.2
- Last updated
- 2026-10-16
- Active installs
- 9,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Collect and embed Instagram feeds, LinkedIn posts, Twitter feeds, YouTube videos, Google Reviews & 20+ social media widgets on your WordPress website. — by Tagembed
What to do
- Update to the latest version (8.2). Anything older than 7.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get tagembed-widget --field=version shows what you run; wp plugin update tagembed-widget updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-66590 · published 2026-08-20
Cross-site scripting (XSS) in Tagembed (7.4 and older)
- Affected
- 7.4 and older
- Fixed in
- 7.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Tagembed <= 7.4 versions.
medium 5.4 CVE-2024-34804 · published 2024-06-11
Missing authorization check in Tagembed (5.8 and older)
- Affected
- 5.8 and older
- Fixed in
- 5.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Tagembed.This issue affects Tagembed: from n/a through 5.8.
medium 6.5 CVE-2024-32561 · published 2024-04-18
Stored cross-site scripting (XSS) in Tagembed (4.7 and older)
- Affected
- 4.7 and older
- Fixed in
- 4.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Tagembed allows Stored XSS.This issue affects Tagembed: from n/a through 4.7.
Recent activity
- 2026-10-16 — latest release on wordpress.org (8.2).
- 2026-08-20 — Cross-site scripting (XSS) disclosed (CVE-2026-66590), fixed in 7.5.
- 2024-06-11 — Missing authorization check disclosed (CVE-2024-34804), fixed in 5.9.
- 2024-04-18 — Stored cross-site scripting (XSS) disclosed (CVE-2024-32561), fixed in 4.9.
Get an email when Tagembed has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Tagembed (tagembed-widget) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/tagembed-widget (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/tagembed-widget"><img src="https://laskyr.com/plugins/tagembed-widget/badge.svg" alt="Tagembed vulnerability status"></a>