Skip to content
Laskyr

Plugins · tablemaster-for-elementor · data as of 2026-11-04

Is TableMaster for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.7)

As of 2026-11-04. 1 issue is on record for older versions; version 1.3.8 or newer fixes all of them that state a fix.

Latest version
1.4.7
Last updated
2026-09-23
Active installs
400+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Build beautiful Elementor tables for comparison, pricing, product, and data with live editing, CSV import, and Google Sheets sync. — by BloomPixel

What to do

  1. Update to the latest version (1.4.7). Anything older than 1.3.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get tablemaster-for-elementor --field=version shows what you run; wp plugin update tablemaster-for-elementor updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2025-14610 · published 2026-01-28

Server-side request forgery (SSRF) in TableMaster for Elementor (1.3.6 and older)

Affected
1.3.6 and older
Fixed in
1.3.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The TableMaster for Elementor plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.3.6. This is due to the plugin not restricting which URLs can be fetched when importing CSV data from a URL in the Data Table widget. This makes it possible for authenticated attackers, with Author-level access and above, to make web requests to arbitrary locations, including localhost and internal network services, and read sensitive files such as wp-config.php via the 'csv_url' parameter.

NVD CVE-2025-14610Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
TableMaster for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/tablemaster-for-elementor"><img src="https://laskyr.com/plugins/tablemaster-for-elementor/badge.svg" alt="TableMaster for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit