Skip to content
Laskyr

Plugins · tableberg · data as of 2026-11-04

Is Tableberg safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.0)

As of 2026-11-04. 2 issues are on record for older versions; version 0.6.12 or newer fixes all of them that state a fix.

Latest version
1.2.0
Last updated
2026-09-30
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Table Block For the Block Editor. Craft Beautiful Tables With Ease. — by Imtiaz Rayhan

What to do

  1. Update to the latest version (1.2.0). Anything older than 0.6.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get tableberg --field=version shows what you run; wp plugin update tableberg updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-66096 · published 2025-11-21

Missing authorization check in Tableberg (0.6.9 and older)

Affected
0.6.9 and older
Fixed in
0.6.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Imtiaz Rayhan Table Block by Tableberg tableberg allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Table Block by Tableberg: from n/a through <= 0.6.9.

NVD CVE-2025-66096Patchstack advisory

medium 6.5 CVE-2025-32171 · published 2025-04-04

Stored cross-site scripting (XSS) in Tableberg (0.6.10 and older)

Affected
0.6.10 and older
Fixed in
0.6.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Imtiaz Rayhan Table Block by Tableberg tableberg allows Stored XSS.This issue affects Table Block by Tableberg: from n/a through <= 0.6.10.

NVD CVE-2025-32171Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Tableberg vulnerability status badge
<a href="https://laskyr.com/plugins/tableberg"><img src="https://laskyr.com/plugins/tableberg/badge.svg" alt="Tableberg vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit