Plugins · sync-post-with-other-site · data as of 2026-11-04
Is Sync Post With Other Site safe? Known vulnerabilities and latest version
- Latest version
- 1.9.3
- Last updated
- 2026-07-06
- Active installs
- 3,000+
- Known issues on record
- 4
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8
Allows user to sync Posts, Pages and Custom Post Type with multiple websites. — by Kamlesh Parmar
What to do
- There is no fixed version yet. If you can live without Sync Post With Other Site for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get sync-post-with-other-site --field=version shows what you run; wp plugin update sync-post-with-other-site updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.9 affects latest 1.9.3 CVE-2026-32463 · published 2026-08-18
Arbitrary file upload in Sync Post With Other Site (1.9.3 and older)
- Affected
- 1.9.3 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Arbitrary File Upload in Sync Post With Other Site <= 1.9.3 versions.
medium 6.5 CVE-2026-14923 · published 2026-07-30
Missing authorization check in Sync Post With Other Site (older than 1.9.3)
- Affected
- older than 1.9.3
- Fixed in
- 1.9.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Sync Post With Other Site WordPress plugin before 1.9.3 does not correctly enforce the page-editing capability on a REST route that creates and updates posts, because of an operator-precedence flaw in its authorization check. An authenticated user holding only the post-editing capability (such as a Contributor) can create, publish, and overwrite arbitrary Pages, including modifying content authored by higher-privileged users.
medium 4.3 CVE-2024-6709 · published 2024-08-03
Missing authorization check in Sync Post With Other Site (1.6 and older)
- Affected
- 1.6 and older
- Fixed in
- 1.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Sync Post With Other Site plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'sps_add_update_post' function in all versions up to, and including, 1.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create new draft posts and update existing posts.
NVD CVE-2024-6709Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-32082 · published 2024-04-15
Cross-site request forgery (CSRF) in Sync Post With Other Site (1.9.1 and older)
- Affected
- 1.9.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Kamlesh Parmar Sync Post With Other Site sync-post-with-other-site allows Cross Site Request Forgery.This issue affects Sync Post With Other Site: from n/a through <= 1.9.1.
Recent activity
- 2026-07-06 — latest release on wordpress.org (1.9.3).
- 2026-08-18 — Arbitrary file upload disclosed (CVE-2026-32463), no fix listed yet.
- 2026-07-30 — Missing authorization check disclosed (CVE-2026-14923), fixed in 1.9.3.
- 2024-08-03 — Missing authorization check disclosed (CVE-2024-6709), fixed in 1.7.
Get an email when Sync Post With Other Site has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Sync Post With Other Site (sync-post-with-other-site) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Arbitrary file upload (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/sync-post-with-other-site (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/sync-post-with-other-site"><img src="https://laskyr.com/plugins/sync-post-with-other-site/badge.svg" alt="Sync Post With Other Site vulnerability status"></a>