Skip to content
Laskyr

Plugins · sweet-energy-efficiency · data as of 2026-11-04

Is Sweet Energy Efficiency safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.9)

As of 2026-11-04. 2 issues are on record for older versions; version 1.0.9 or newer fixes all of them that state a fix.

Latest version
1.0.9
Last updated
2026-01-26
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Graphically Visually present Energy Efficiency Class / Label / Rating / Scale with related consumption values — by WPDirectoryKit

What to do

  1. Update to the latest version (1.0.9). Anything older than 1.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sweet-energy-efficiency --field=version shows what you run; wp plugin update sweet-energy-efficiency updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-14618 · published 2025-12-18

Missing authorization check in Sweet Energy Efficiency (1.0.6 and older)

Affected
1.0.6 and older
Fixed in
1.0.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Sweet Energy Efficiency plugin for WordPress is vulnerable to unauthorized access, modification, and loss of data due to a missing capability check on the 'sweet_energy_efficiency_action' AJAX handler in all versions up to, and including, 1.0.6. This makes it possible for authenticated attackers, with subscriber level access and above, to read, modify, and delete arbitrary graphs.

NVD CVE-2025-14618Wordfence advisoryCode change (fix)

high 7.1 CVE-2025-58262 · published 2025-09-22

Cross-site request forgery (CSRF) in Sweet Energy Efficiency (1.0.8 and older)

Affected
1.0.8 and older
Fixed in
1.0.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WPDirectoryKit Sweet Energy Efficiency sweet-energy-efficiency allows Stored XSS.This issue affects Sweet Energy Efficiency: from n/a through <= 1.0.8.

NVD CVE-2025-58262Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Sweet Energy Efficiency vulnerability status badge
<a href="https://laskyr.com/plugins/sweet-energy-efficiency"><img src="https://laskyr.com/plugins/sweet-energy-efficiency/badge.svg" alt="Sweet Energy Efficiency vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit