Skip to content
Laskyr

Plugins · swatchly · data as of 2026-11-04

Is Swatchly safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.17)

As of 2026-11-04. 3 issues are on record for older versions; version 1.4.14 or newer fixes all of them that state a fix.

Latest version
1.4.17
Last updated
2026-10-08
Active installs
5,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Product Variation Swatches For WooCommerce Products. — by HasThemes

What to do

  1. Update to the latest version (1.4.17). Anything older than 1.4.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get swatchly --field=version shows what you run; wp plugin update swatchly updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-66605 · published 2026-08-20

Cross-site scripting (XSS) in Swatchly (1.4.13 and older)

Affected
1.4.13 and older
Fixed in
1.4.14
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Swatchly – WooCommerce Variation Swatches for Products <= 1.4.13 versions.

NVD CVE-2026-66605Patchstack advisory

medium 6.5 CVE-2025-2719 · published 2025-04-10

Missing authorization check in Swatchly (1.2.8 to 1.4.0)

Affected
1.2.8 to 1.4.0
Fixed in
1.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Swatchly – WooCommerce Variation Swatches for Products (product attributes: Image swatch, Color swatches, Label swatches) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ajax_dismiss function in versions 1.2.8 to 1.4.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update option values to 1/true on the WordPress site. This can be leveraged to update an option that would create an error on the site and deny access to legitimate users or be used to set some values to true, such as registration.

NVD CVE-2025-2719Wordfence advisoryPlugin source

high 8.8 CVE-2023-23792 · published 2023-07-11

Cross-site request forgery (CSRF) in Swatchly (1.2.0 and older)

Affected
1.2.0 and older
Fixed in
1.2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in HasThemes Swatchly plugin <= 1.2.0 versions.

NVD CVE-2023-23792Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Swatchly vulnerability status badge
<a href="https://laskyr.com/plugins/swatchly"><img src="https://laskyr.com/plugins/swatchly/badge.svg" alt="Swatchly vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit