Skip to content
Laskyr

Plugins · svg-support · data as of 2026-11-01

Is SVG Support safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.3)

As of 2026-11-01. 7 issues are on record for older versions; version 2.5.17 or newer fixes all of them that state a fix.

Latest version
2.6.3
Last updated
2026-10-31
Active installs
1+ million
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Securely upload SVG files to your media library, with built-in sanitization and advanced features for styling and animation. — by Benbodhi

What to do

  1. Update to the latest version (2.6.3). Anything older than 2.5.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get svg-support --field=version shows what you run; wp plugin update svg-support updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-13340 · published 2026-08-03

Cross-site scripting (XSS) in SVG Support (older than 2.5.17)

Affected
older than 2.5.17
Fixed in
2.5.17
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The SVG Support WordPress plugin before 2.5.17 does not apply its SVG sanitisation to uploaded files using the .svgz extension, even though it registers and serves them as SVG, allowing a user permitted to upload SVGs (such as an Author once granted upload access) to store a script-bearing file that executes in the browser of anyone who later views it, including an administrator.

NVD CVE-2026-13340WPScan advisory

medium 4.3 CVE-2026-48973 · published 2026-05-27

Missing authorization check in SVG Support (2.5.14 and older)

Affected
2.5.14 and older
Fixed in
2.5.15 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Benbodhi SVG Support allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects SVG Support: from n/a through 2.5.14.

NVD CVE-2026-48973Patchstack advisory

medium 5.4 CVE-2024-10222 · published 2025-02-21

Stored cross-site scripting (XSS) in SVG Support (2.5.10 and older)

Affected
2.5.10 and older
Fixed in
2.5.11 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 2.5.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file. By default, this can only be exploited by administrators, but the ability to upload SVG files can be extended to authors.

NVD CVE-2024-10222Wordfence advisoryCode change (fix)wordpress.orggithub.com

medium 5.4 CVE-2023-6708 · published 2024-07-18

Stored cross-site scripting (XSS) in SVG Support (2.5.7 and older)

Affected
2.5.7 and older
Fixed in
2.5.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the SVG upload feature in all versions up to, and including, 2.5.7 due to insufficient input sanitization and output escaping, even when the 'Sanitize SVG while uploading' feature is enabled. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note that successful exploitation of this vulnerability requires the administrator to allow author-level users to upload SVG files. As of 2.5.6, SVG sanitization can still be bypassed by supplying a content-type other than image/svg+xml.

NVD CVE-2023-6708Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.4 CVE-2022-4022 · published 2022-11-16

Cross-site scripting (XSS) in SVG Support (2.5 only, 2.5.1 only)

Affected
2.5 only, 2.5.1 only
Fixed in
2.5.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The SVG Support plugin for WordPress defaults to insecure settings in version 2.5 and 2.5.1. SVG files containing malicious javascript are not sanitized. While version 2.5 adds the ability to sanitize image as they are uploaded, the plugin defaults to disable sanitization and does not restrict SVG upload to only administrators. This allows authenticated attackers, with author-level privileges and higher, to upload malicious SVG files that can be embedded in posts and pages by higher privileged users. Additionally, the embedded JavaScript is also triggered on visiting the image URL, which allows an attacker to execute malicious code in browsers visiting that URL.

NVD CVE-2022-4022Code change (fix)Wordfence advisory

medium 5.4 CVE-2022-1755 · published 2022-09-26

Cross-site scripting (XSS) in SVG Support (older than 2.5.0)

Affected
older than 2.5.0
Fixed in
2.5.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The SVG Support WordPress plugin before 2.5 does not properly handle SVG added via an URL, which could allow users with a role as low as author to perform Cross-Site Scripting attacks

NVD CVE-2022-1755WPScan advisory

medium 4.8 CVE-2021-24686 · published 2022-02-01

Cross-site scripting (XSS) in SVG Support (older than 2.3.20)

Affected
older than 2.3.20
Fixed in
2.3.20
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The SVG Support WordPress plugin before 2.3.20 does not escape the "CSS Class to target" setting before outputting it in an attribute, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

NVD CVE-2021-24686WPScan advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SVG Support vulnerability status badge
<a href="https://laskyr.com/plugins/svg-support"><img src="https://laskyr.com/plugins/svg-support/badge.svg" alt="SVG Support vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit