Plugins · surferseo · data as of 2026-11-04
Is Surfer safe? Known vulnerabilities and latest version
- Latest version
- 1.8.1.759
- Last updated
- 2026-10-19
- Active installs
- 5,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Connect Surfer's Content Editor to WordPress. Write and optimize your articles for SEO, find new keyword ideas and publish straight to WordPress. — by Surfer
What to do
- Update to the latest version (1.8.1.759). Anything older than 1.8.1.759 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get surferseo --field=version shows what you run; wp plugin update surferseo updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-112222 · published 2026-10-19
Missing authorization check in Surfer (1.8.0.744 and older)
- Affected
- 1.8.0.744 and older
- Fixed in
- 1.8.1.759
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Surfer Surfer surferseo allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Surfer: from n/a through 1.8.0.744.
medium 5.3 CVE-2025-58603 · published 2025-09-03
Missing authorization check in Surfer (1.6.4.574 and older)
- Affected
- 1.6.4.574 and older
- Fixed in
- 1.6.5.584
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Surfer Surfer surferseo allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Surfer: from n/a through <= 1.6.4.574.
high 7.6 CVE-2023-35037 · published 2024-12-13
Missing authorization check in Surfer (1.3.2.357 and older)
- Affected
- 1.3.2.357 and older
- Fixed in
- 1.3.3.379
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Surfer Surfer surferseo allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Surfer: from n/a through <= 1.3.2.357.
high 7.6 CVE-2024-49299 · published 2024-10-17
SQL injection in Surfer (1.5.0.502 and older)
- Affected
- 1.5.0.502 and older
- Fixed in
- 1.6.0.523
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Surfer Surfer surferseo allows SQL Injection.This issue affects Surfer: from n/a through <= 1.5.0.502.
Recent activity
- 2026-10-19 — latest release on wordpress.org (1.8.1.759).
- 2026-10-19 — Missing authorization check disclosed (CVE-2026-112222), fixed in 1.8.1.759.
- 2025-09-03 — Missing authorization check disclosed (CVE-2025-58603), fixed in 1.6.5.584.
- 2024-12-13 — Missing authorization check disclosed (CVE-2023-35037), fixed in 1.3.3.379.
Get an email when Surfer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Surfer (surferseo) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/surferseo (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/surferseo"><img src="https://laskyr.com/plugins/surferseo/badge.svg" alt="Surfer vulnerability status"></a>