Skip to content
Laskyr

Plugins · suretriggers · data as of 2026-11-04

Is OttoKit safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.43)

As of 2026-11-04. 9 issues are on record for older versions; version 1.1.41 or newer fixes all of them that state a fix.

Latest version
1.1.43
Last updated
2026-10-29
Active installs
90,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Experience the power of automation within WordPress: Connect 1,600+ apps, automate manual tasks, and unlock your full potential. Get started now! — by Brainstorm Force

What to do

  1. Update to the latest version (1.1.43). Anything older than 1.1.41 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get suretriggers --field=version shows what you run; wp plugin update suretriggers updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-110372 · published 2026-10-18

Privilege escalation in OttoKit (1.1.40 and older)

Affected
1.1.40 and older
Fixed in
1.1.41
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Brainstorm Force OttoKit suretriggers allows Privilege Escalation.This issue affects OttoKit: from n/a through 1.1.40.

NVD CVE-2026-110372Patchstack advisory

high 7.2 CVE-2026-32553 · published 2026-08-18

Server-side request forgery (SSRF) in OttoKit (1.1.35 and older)

Affected
1.1.35 and older
Fixed in
1.1.36
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Server Side Request Forgery (SSRF) in OttoKit <= 1.1.35 versions.

NVD CVE-2026-32553Patchstack advisory

critical 9.8 CVE-2026-49781 · published 2026-06-15

PHP object injection in OttoKit (1.1.27 and older)

Affected
1.1.27 and older
Fixed in
1.1.28
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated PHP Object Injection in OttoKit <= 1.1.27 versions.

NVD CVE-2026-49781Patchstack advisory

high 8.6 CVE-2026-4935 · published 2026-05-08

SQL injection in OttoKit (older than 1.1.23)

Affected
older than 1.1.23
Fixed in
1.1.23
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The OttoKit: All-in-One Automation Platform WordPress plugin before 1.1.23 does not properly sanitize user input before using it in a SQL statement, which could allow unauthenticated attackers to perform SQL injection attacks.

NVD CVE-2026-4935WPScan advisory

high 7.6 CVE-2026-39479 · published 2026-04-08

SQL injection in OttoKit (1.1.20 and older)

Affected
1.1.20 and older
Fixed in
1.1.21
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Brainstorm Force OttoKit suretriggers allows Blind SQL Injection.This issue affects OttoKit: from n/a through <= 1.1.20.

NVD CVE-2026-39479Patchstack advisory

critical 9.8 CVE-2025-27007 · published 2025-05-01

Privilege escalation in OttoKit (1.0.82 and older)

Affected
1.0.82 and older
Fixed in
1.0.83
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Brainstorm Force OttoKit suretriggers allows Privilege Escalation.This issue affects OttoKit: from n/a through <= 1.0.82.

NVD CVE-2025-27007Patchstack advisory

high 8.1 CVE-2025-3102 · published 2025-04-10

Authentication bypass in OttoKit (1.0.78 and older)

Affected
1.0.78 and older
Fixed in
1.0.79 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SureTriggers: All-in-One Automation Platform plugin for WordPress is vulnerable to an authentication bypass leading to administrative account creation due to a missing empty value check on the 'secret_key' value in the 'autheticate_user' function in all versions up to, and including, 1.0.78. This makes it possible for unauthenticated attackers to create administrator accounts on the target website when the plugin is installed and activated but not configured with an API key.

NVD CVE-2025-3102Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2024-5485 · published 2024-06-04

Stored cross-site scripting (XSS) in OttoKit (1.0.47 and older)

Affected
1.0.47 and older
Fixed in
1.0.48 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SureTriggers – Connect All Your Plugins, Apps, Tools & Automate Everything! plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Trigger Link shortcode in all versions up to, and including, 1.0.47 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5485Wordfence advisoryCode change (fix)wordpress.org

high 8.8 CVE-2023-49749 · published 2023-12-15

Cross-site request forgery (CSRF) in OttoKit (1.0.23 and older)

Affected
1.0.23 and older
Fixed in
1.0.24
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in SureTriggers SureTriggers – Connect All Your Plugins, Apps, Tools & Automate Everything!.This issue affects SureTriggers – Connect All Your Plugins, Apps, Tools & Automate Everything!: from n/a through 1.0.23.

NVD CVE-2023-49749Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
OttoKit vulnerability status badge
<a href="https://laskyr.com/plugins/suretriggers"><img src="https://laskyr.com/plugins/suretriggers/badge.svg" alt="OttoKit vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit