Plugins · surbma-infusionsoft-shortcode · data as of 2026-11-04
Is Surbma safe? Known vulnerabilities and latest version
- Latest version
- 2.0.2
- Last updated
- 2026-06-22
- Active installs
- 10+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.0+
A simple shortcode to include Infusionsoft forms into WordPress. — by Surbma
What to do
- Update to the latest version (2.0.2). Anything older than 2.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get surbma-infusionsoft-shortcode --field=version shows what you run; wp plugin update surbma-infusionsoft-shortcode updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-11597 · published 2026-06-27
Stored cross-site scripting (XSS) in Surbma (2.0.1 and older)
- Affected
- 2.0.1 and older
- Fixed in
- 2.0.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Surbma | Infusionsoft Shortcode plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'infusionsoft-form' shortcode in versions up to, and including, 2.0.1. This is due to insufficient input sanitization and output escaping on user-supplied 'account' and 'id' shortcode attributes in the surbma_infusionsoft_shortcode_shortcode() function, which are concatenated directly into a <script> tag's src attribute. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-11597Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-06-22 — latest release on wordpress.org (2.0.2).
- 2026-06-27 — Stored cross-site scripting (XSS) disclosed (CVE-2026-11597), fixed in 2.0.2.
Get an email when Surbma has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Surbma (surbma-infusionsoft-shortcode) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Surbma (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/surbma-infusionsoft-shortcode (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/surbma-infusionsoft-shortcode"><img src="https://laskyr.com/plugins/surbma-infusionsoft-shortcode/badge.svg" alt="Surbma vulnerability status"></a>