Skip to content
Laskyr

Plugins · surbma-bookingcom-shortcode · data as of 2026-11-04

Is Surbma safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.1)

As of 2026-11-04. 1 issue is on record for older versions; version 2.1.1 or newer fixes all of them that state a fix.

Latest version
2.1.1
Last updated
2026-04-12
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

A simple shortcode to include Booking.com search box into WordPress. — by Surbma

What to do

  1. Update to the latest version (2.1.1). Anything older than 2.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get surbma-bookingcom-shortcode --field=version shows what you run; wp plugin update surbma-bookingcom-shortcode updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1607 · published 2026-04-14

Stored cross-site scripting (XSS) in Surbma (2.1 and older)

Affected
2.1 and older
Fixed in
2.1.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Surbma | Booking.com Shortcode plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `surbma-bookingcom` shortcode in all versions up to, and including, 2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1607Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Surbma vulnerability status badge
<a href="https://laskyr.com/plugins/surbma-bookingcom-shortcode"><img src="https://laskyr.com/plugins/surbma-bookingcom-shortcode/badge.svg" alt="Surbma vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit