Skip to content
Laskyr

Plugins · supreme-modules-for-divi · data as of 2026-11-04

Is Supreme Modules Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.65)

As of 2026-11-04. 4 issues are on record for older versions; version 2.5.64 or newer fixes all of them that state a fix.

Latest version
2.5.65
Last updated
2026-10-29
Active installs
100,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Divi Supreme lite plugin enhances the experience and features found on Divi and extend with custom creative modules to help you build amazing websites … — by Supreme Modules

What to do

  1. Update to the latest version (2.5.65). Anything older than 2.5.64 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get supreme-modules-for-divi --field=version shows what you run; wp plugin update supreme-modules-for-divi updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-102384 · published 2026-09-30

Cross-site scripting (XSS) in Supreme Modules Lite (2.5.63 and older)

Affected
2.5.63 and older
Fixed in
2.5.64
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Author Cross Site Scripting (XSS) in Supreme Modules Lite <= 2.5.63 versions.

NVD CVE-2026-102384Patchstack advisory

high 8.8 CVE-2025-13062 · published 2026-01-15

Arbitrary file upload in Supreme Modules Lite (2.5.62 and older)

Affected
2.5.62 and older
Fixed in
2.5.63 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Supreme Modules Lite plugin for WordPress is vulnerable to arbitrary file upload in all versions up to, and including, 2.5.62. This is due to insufficient file type validation detecting JSON files, allowing double extension files to bypass sanitization while being accepted as a valid JSON file. This makes it possible for authenticated attackers, with author-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2025-13062Wordfence advisoryCode change (fix)

medium 6.4 CVE-2024-5501 · published 2024-06-01

Stored cross-site scripting (XSS) in Supreme Modules Lite (2.5.51 and older)

Affected
2.5.51 and older
Fixed in
2.5.52 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘button_one_id’ parameter in all versions up to, and including, 2.5.51 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5501Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2024-4334 · published 2024-05-02

DOM-based cross-site scripting (XSS) in Supreme Modules Lite (2.5.3 and older)

Affected
2.5.3 and older
Fixed in
2.5.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder plugin for WordPress is vulnerable to DOM-Based Cross-Site Scripting via the ‘typing_cursor’ parameter in versions up to, and including, 2.5.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4334Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Supreme Modules Lite vulnerability status badge
<a href="https://laskyr.com/plugins/supreme-modules-for-divi"><img src="https://laskyr.com/plugins/supreme-modules-for-divi/badge.svg" alt="Supreme Modules Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit