Skip to content
Laskyr

Plugins · support-genix-lite · data as of 2026-11-04

Is Support Genix safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.58)

As of 2026-11-04. 7 issues are on record for older versions; version 1.4.55 or newer fixes all of them that state a fix.

Latest version
1.4.58
Last updated
2026-11-03
Active installs
3,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

AI-powered helpdesk & support ticket system with chatbot, knowledge base, and smart automation for WordPress. — by DevItems

What to do

  1. Update to the latest version (1.4.58). Anything older than 1.4.55 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get support-genix-lite --field=version shows what you run; wp plugin update support-genix-lite updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2026-110895 · published 2026-10-18

SQL injection in Support Genix (1.4.54 and older)

Affected
1.4.54 and older
Fixed in
1.4.55
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in DevItems Support Genix support-genix-lite allows SQL Injection.This issue affects Support Genix: from n/a through 1.4.54.

NVD CVE-2026-110895Patchstack advisory

high 8.8 CVE-2026-19806 · published 2026-09-01

Authentication bypass in Support Genix (1.4.52 and older)

Affected
1.4.52 and older
Fixed in
1.4.53 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Support Genix – Helpdesk, AI Chatbot, Knowledge Base & Customer Support Ticketing System plugin for WordPress is vulnerable to Authentication Bypass leading to Administrator Account Takeover in all versions up to, and including, 1.4.52 via the `guest_ticket_login()` function and its `p` parameter. This is due to the site-wide AES-256-CBC encryption key being derived from only three two-digit `wp_rand(10, 99)` values and a Unix timestamp via `md5()` — yielding approximately 19.5 bits of entropy — combined with a deterministic IV derived from the password, no authentication tag on the ciphertext, and no capability check, nonce, or session validation on the publicly reachable `/sgnix/?p=<token>` endpoint. This makes it possible for authenticated attackers, with subscriber-level access and above, who can obtain a single legitimate guest ticket token as a known-plaintext oracle and bound the plugin activation timestamp, to exhaust the ~729,000-candidate keyspace entirely offline, recover the site-wide encryption key, and forge a self-consistent `{ticket_id, ticket_user}` token targeting any administrator-owned ticket. Submitting the forged token to the unprotected endpoint causes `wp_set_auth_cookie()` to be called for that administrator, granting the attacker full administrative access to the WordPress site.

NVD CVE-2026-19806Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2026-15932 · published 2026-08-01

Path traversal / file read in Support Genix (older than 1.4.48)

Affected
older than 1.4.48
Fixed in
1.4.48
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Support Genix WordPress plugin before 1.4.48 does not prevent directory traversal in its ticket-attachment download route, allowing unauthenticated attackers to read arbitrary files with an allowlisted extension — including other users' private ticket attachments — from the server.

NVD CVE-2026-15932WPScan advisory

low 3.7 CVE-2026-14862 · published 2026-07-31

Missing authorization check in Support Genix (older than 1.4.48)

Affected
older than 1.4.48
Fixed in
1.4.48
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Support Genix WordPress plugin before 1.4.48 does not properly authorize access to support-ticket attachment downloads, allowing unauthenticated users who obtain the stored attachment file name to download other users' private ticket attachments.

NVD CVE-2026-14862WPScan advisory

medium 5.3 CVE-2025-58635 · published 2025-09-03

Missing authorization check in Support Genix (1.4.23 and older)

Affected
1.4.23 and older
Fixed in
1.4.24
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in DevItems Support Genix support-genix-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Support Genix: from n/a through <= 1.4.23.

NVD CVE-2025-58635Patchstack advisory

medium 4.3 CVE-2025-30777 · published 2025-03-27

Missing authorization check in Support Genix (1.4.11 and older)

Affected
1.4.11 and older
Fixed in
1.4.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in DevItems Support Genix support-genix-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Support Genix: from n/a through <= 1.4.11.

NVD CVE-2025-30777Patchstack advisory

critical 9.9 CVE-2023-49742 · published 2024-04-18

Missing authorization check in Support Genix (1.2.3 and older)

Affected
1.2.3 and older
Fixed in
1.2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Support Genix.This issue affects Support Genix: from n/a through 1.2.3.

NVD CVE-2023-49742Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Support Genix vulnerability status badge
<a href="https://laskyr.com/plugins/support-genix-lite"><img src="https://laskyr.com/plugins/support-genix-lite/badge.svg" alt="Support Genix vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit