Plugins · super-progressive-web-apps · data as of 2026-11-04
Is Super Progressive Web Apps safe? Known vulnerabilities and latest version
- Latest version
- 2.2.49
- Last updated
- 2026-10-19
- Active installs
- 40,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.3+
SuperPWA helps you convert your WordPress website into a Progressive Web App instantly. — by SuperPWA
What to do
- Update to the latest version (2.2.49). Anything older than 2.2.44 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get super-progressive-web-apps --field=version shows what you run; wp plugin update super-progressive-web-apps updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2026-5108 · published 2026-08-05
Stored cross-site scripting (XSS) in Super Progressive Web Apps (2.2.43 and older)
- Affected
- 2.2.43 and older
- Fixed in
- 2.2.44 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Super Progressive Web Apps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `superpwa_settings[offline_message_txt]` setting in all versions up to, and including, 2.2.43. This is due to insufficient input sanitization and output escaping. The offline message value is stored without sanitization, passed to the frontend via `wp_localize_script()` without escaping, and rendered using `innerHTML` in the JavaScript snackbar component. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user triggers the offline snackbar.
NVD CVE-2026-5108Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2023-48277 · published 2024-12-09
Missing authorization check in Super Progressive Web Apps (2.2.21 and older)
- Affected
- 2.2.21 and older
- Fixed in
- 2.2.22
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in SuperPWA Super Progressive Web Apps super-progressive-web-apps allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Super Progressive Web Apps: from n/a through <= 2.2.21.
Recent activity
- 2026-10-19 — latest release on wordpress.org (2.2.49).
- 2026-08-05 — Stored cross-site scripting (XSS) disclosed (CVE-2026-5108), fixed in 2.2.44.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-48277), fixed in 2.2.22.
Get an email when Super Progressive Web Apps has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Super Progressive Web Apps (super-progressive-web-apps) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/super-progressive-web-apps (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/super-progressive-web-apps"><img src="https://laskyr.com/plugins/super-progressive-web-apps/badge.svg" alt="Super Progressive Web Apps vulnerability status"></a>