Skip to content
Laskyr

Plugins · sugar-calendar-lite · data as of 2026-11-04

Is Sugar Calendar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.16.0)

As of 2026-11-04. 2 issues are on record for older versions; version 3.10.0 or newer fixes all of them that state a fix.

Latest version
3.16.0
Last updated
2026-10-15
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Easily manage events and sell tickets on your WordPress site. Sugar Calendar is easy-to-use, reliable, and exceptionally powerful. See for yourself. — by Syed Balkhi

What to do

  1. Update to the latest version (3.16.0). Anything older than 3.10.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sugar-calendar-lite --field=version shows what you run; wp plugin update sugar-calendar-lite updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-24636 · published 2026-01-23

Missing authorization check in Sugar Calendar (3.9.1 and older)

Affected
3.9.1 and older
Fixed in
3.10.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Syed Balkhi Sugar Calendar (Lite) sugar-calendar-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Sugar Calendar (Lite): from n/a through <= 3.9.1.

NVD CVE-2026-24636Patchstack advisory

medium 6.1 CVE-2024-10878 · published 2024-11-26

Reflected cross-site scripting (XSS) in Sugar Calendar (3.3.0 and older)

Affected
3.3.0 and older
Fixed in
3.4.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Sugar Calendar – Simple Event Management plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.3.0. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-10878Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Sugar Calendar vulnerability status badge
<a href="https://laskyr.com/plugins/sugar-calendar-lite"><img src="https://laskyr.com/plugins/sugar-calendar-lite/badge.svg" alt="Sugar Calendar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit