Skip to content
Laskyr

Plugins · subscription · data as of 2026-11-04

Is Subscriptions for WooCommerce with Stripe Recu… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.9.2 or newer fixes all of them that state a fix.

Latest version
2.5.0
Last updated
2026-10-27
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WooCommerce subscriptions made simple: flexible billing cycles, automated recurring payments and built-in Stripe and PayPal support. — by Convers Lab

What to do

  1. Update to the latest version (2.5.0). Anything older than 1.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get subscription --field=version shows what you run; wp plugin update subscription updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-24554 · published 2026-05-25

Cross-site request forgery (CSRF) in Subscriptions for WooCommerce with Stripe Recu… (1.9.1 and older)

Affected
1.9.1 and older
Fixed in
1.9.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Convers Lab WPSubscription allows Cross Site Request Forgery. This issue affects WPSubscription: from n/a through 1.9.1.

NVD CVE-2026-24554Patchstack advisory

high 8.6 CVE-2025-69347 · published 2026-03-25

Missing authorization check in Subscriptions for WooCommerce with Stripe Recu… (1.8.10 and older)

Affected
1.8.10 and older
Fixed in
1.8.11
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in Convers Lab WPSubscription subscription allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WPSubscription: from n/a through <= 1.8.10.

NVD CVE-2025-69347Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Subscriptions for WooCommerce with Stripe Recu… vulnerability status badge
<a href="https://laskyr.com/plugins/subscription"><img src="https://laskyr.com/plugins/subscription/badge.svg" alt="Subscriptions for WooCommerce with Stripe Recu… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit