Skip to content
Laskyr

Plugins · stylish-price-list · data as of 2026-11-04

Is Stylish Price List safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.2.16)

As of 2026-11-04. 6 issues are on record for older versions; version 7.2.3 or newer fixes all of them that state a fix.

Latest version
7.2.16
Last updated
2026-10-12
Active installs
3,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Stop Losing Customers Due to Confusing Pricing - Transform confused visitors into paying customers with crystal-clear price lists that increase conver … — by Design

What to do

  1. Update to the latest version (7.2.16). Anything older than 7.2.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get stylish-price-list --field=version shows what you run; wp plugin update stylish-price-list updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-66122 · published 2025-12-16

Missing authorization check in Stylish Price List (7.2.2 and older)

Affected
7.2.2 and older
Fixed in
7.2.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Design Stylish Price List stylish-price-list allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Stylish Price List: from n/a through <= 7.2.2.

NVD CVE-2025-66122Patchstack advisory

medium 4.8 CVE-2024-7758 · published 2025-05-15

Stored cross-site scripting (XSS) in Stylish Price List (older than 7.1.8)

Affected
older than 7.1.8
Fixed in
7.1.8
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Stylish Price List WordPress plugin before 7.1.8 does not sanitise and escape some of its settings, which could allow high privilege users of contributor and above to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2024-7758WPScan advisory

medium 5.9 CVE-2024-10472 · published 2025-03-25

Stored cross-site scripting (XSS) in Stylish Price List (older than 7.1.12)

Affected
older than 7.1.12
Fixed in
7.1.12
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Stylish Price List WordPress plugin before 7.1.12 does not sanitise and escape some of its settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2024-10472WPScan advisory

critical 9.8 CVE-2023-51673 · published 2024-01-05

Cross-site request forgery (CSRF) in Stylish Price List (7.0.17 and older)

Affected
7.0.17 and older
Fixed in
7.0.18
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Designful Stylish Price List – Price Table Builder & QR Code Restaurant Menu.This issue affects Stylish Price List – Price Table Builder & QR Code Restaurant Menu: from n/a through 7.0.17.

NVD CVE-2023-51673Patchstack advisory

medium 5.3 CVE-2021-24757 · published 2021-11-01

Missing authorization check in Stylish Price List (older than 6.9.0)

Affected
older than 6.9.0
Fixed in
6.9.0
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The Stylish Price List WordPress plugin before 6.9.0 does not perform capability checks in its spl_upload_ser_img AJAX action (available to both unauthenticated and authenticated users), which could allow unauthenticated users to upload images.

NVD CVE-2021-24757WPScan advisory

medium 6.5 CVE-2021-24770 · published 2021-11-01

Missing authorization check in Stylish Price List (older than 6.9.1)

Affected
older than 6.9.1
Fixed in
6.9.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
NVD analysis · score by NVD
Details from the advisory

The Stylish Price List WordPress plugin before 6.9.1 does not perform capability checks in its spl_upload_ser_img AJAX action (available to authenticated users), which could allow any authenticated users, such as subscriber, to upload arbitrary images.

NVD CVE-2021-24770WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Stylish Price List vulnerability status badge
<a href="https://laskyr.com/plugins/stylish-price-list"><img src="https://laskyr.com/plugins/stylish-price-list/badge.svg" alt="Stylish Price List vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit