Plugins · stylish-cost-calculator · data as of 2026-11-04
Is Stylish Cost Calculator safe? Known vulnerabilities and latest version
- Latest version
- 8.5.7
- Last updated
- 2026-10-27
- Active installs
- 1,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Cost calculator for WordPress: 🌟 Engage visitors and boost conversions with interactive calculations, lead capture, and payment integrations. — by Design
What to do
- Update to the latest version (8.5.7). Anything older than 8.3.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get stylish-cost-calculator --field=version shows what you run; wp plugin update stylish-cost-calculator updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-54847 · published 2026-06-26
Missing authorization check in Stylish Cost Calculator (8.3.9 and older)
- Affected
- 8.3.9 and older
- Fixed in
- 8.3.10
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Stylish Cost Calculator <= 8.3.9 versions.
medium 6.5 CVE-2026-24630 · published 2026-01-23
Stored cross-site scripting (XSS) in Stylish Cost Calculator (8.2.9 and older)
- Affected
- 8.2.9 and older
- Fixed in
- 8.3.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Design Stylish Cost Calculator stylish-cost-calculator allows Stored XSS.This issue affects Stylish Cost Calculator: from n/a through <= 8.2.9.
medium 6.5 CVE-2025-66091 · published 2025-11-21
Cross-site scripting (XSS) in Stylish Cost Calculator (8.1.5 and older)
- Affected
- 8.1.5 and older
- Fixed in
- 8.1.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Design Stylish Cost Calculator stylish-cost-calculator allows DOM-Based XSS.This issue affects Stylish Cost Calculator: from n/a through <= 8.1.5.
medium 5.4 CVE-2021-24822 · published 2021-11-29
Cross-site request forgery (CSRF) in Stylish Cost Calculator (older than 7.0.4)
- Affected
- older than 7.0.4
- Fixed in
- 7.0.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Stylish Cost Calculator WordPress plugin before 7.0.4 does not have any authorisation and CSRF checks on some of its AJAX actions (available to authenticated users), which could allow any authenticated users, such as subscriber to call them, and perform Stored Cross-Site Scripting attacks against logged in admin, as well as frontend users due to the lack of sanitisation and escaping in some parameters
Recent activity
- 2026-10-27 — latest release on wordpress.org (8.5.7).
- 2026-06-26 — Missing authorization check disclosed (CVE-2026-54847), fixed in 8.3.10.
- 2026-01-23 — Stored cross-site scripting (XSS) disclosed (CVE-2026-24630), fixed in 8.3.1.
- 2025-11-21 — Cross-site scripting (XSS) disclosed (CVE-2025-66091), fixed in 8.1.6.
Get an email when Stylish Cost Calculator has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Stylish Cost Calculator (stylish-cost-calculator) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Design (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/stylish-cost-calculator (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/stylish-cost-calculator"><img src="https://laskyr.com/plugins/stylish-cost-calculator/badge.svg" alt="Stylish Cost Calculator vulnerability status"></a>