Skip to content
Laskyr

Plugins · styles-and-layouts-for-gravity-forms · data as of 2026-11-04

Is Gravity Booster safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.1)

As of 2026-11-04. 2 issues are on record for older versions; version 6.1 or newer fixes all of them that state a fix.

Latest version
6.1
Last updated
2026-08-18
Active installs
30,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Design and style Gravity Forms without writing CSS. Includes material, checkbox and radio stylers, bootstrap support and theme packs. — by wpmonks

What to do

  1. Update to the latest version (6.1). Anything older than 6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get styles-and-layouts-for-gravity-forms --field=version shows what you run; wp plugin update styles-and-layouts-for-gravity-forms updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-74004 · published 2026-08-18

Missing authorization check in Gravity Booster (6.0 and older)

Affected
6.0 and older
Fixed in
6.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in Gravity Booster &#8211; Styles &amp; Layouts for Gravity Forms <= 6.0 versions.

NVD CVE-2026-74004Patchstack advisory

medium 4.4 CVE-2026-12477 · published 2026-08-16

Stored cross-site scripting (XSS) in Gravity Booster (5.26 and older)

Affected
5.26 and older
Fixed in
6.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gravity Booster – Styles & Layouts for Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 5.26 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with editor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-12477Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Gravity Booster vulnerability status badge
<a href="https://laskyr.com/plugins/styles-and-layouts-for-gravity-forms"><img src="https://laskyr.com/plugins/styles-and-layouts-for-gravity-forms/badge.svg" alt="Gravity Booster vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit