Skip to content
Laskyr

Plugins · stripe-payments · data as of 2026-11-04

Is Accept Stripe Payments safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.4)

As of 2026-11-04. 8 issues are on record for older versions; version 2.1.4 or newer fixes all of them that state a fix.

Latest version
2.1.4
Last updated
2026-09-02
Active installs
20,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Easily accept payments on your WordPress site via Stripe payment gateway. — by mra13 / Team Tips and Tricks HQ

What to do

  1. Update to the latest version (2.1.4). Anything older than 2.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get stripe-payments --field=version shows what you run; wp plugin update stripe-payments updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-81423 · published 2026-09-05

Open redirect in Accept Stripe Payments (older than 2.1.4)

Affected
older than 2.1.4
Fixed in
2.1.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Accept Stripe Payments WordPress plugin before 2.1.4 does not validate a user-supplied URL before using it in a redirect, allowing unauthenticated attackers to redirect visitors to an arbitrary external website, which can be leveraged for phishing.

NVD CVE-2026-81423WPScan advisory

medium 5.3 CVE-2026-81424 · published 2026-09-05

Missing authorization check in Accept Stripe Payments (older than 2.1.4)

Affected
older than 2.1.4
Fixed in
2.1.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Accept Stripe Payments WordPress plugin before 2.1.4 does not verify that the product fulfilled when a checkout is completed matches the product the authoritative payment was actually made for, checking only that the amount paid is at least the referenced product's price, allowing unauthenticated attackers who complete a genuine payment to obtain fulfilment for a different, equal- or lower-priced product than the one they paid for.

NVD CVE-2026-81424WPScan advisory

high 7.1 CVE-2026-78282 · published 2026-08-24

Cross-site scripting (XSS) in Accept Stripe Payments (2.1.2 and older)

Affected
2.1.2 and older
Fixed in
2.1.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Stripe Payments <= 2.1.2 versions.

NVD CVE-2026-78282Patchstack advisory

medium 6.5 CVE-2026-42752 · published 2026-06-15

Security issue in Accept Stripe Payments (2.0.98 and older)

Affected
2.0.98 and older
Fixed in
2.0.99
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Bypass Vulnerability in Stripe Payments <= 2.0.98 versions.

NVD CVE-2026-42752Patchstack advisory

high 8.2 CVE-2023-48286 · published 2024-12-09

Missing authorization check in Accept Stripe Payments (2.0.79 and older)

Affected
2.0.79 and older
Fixed in
2.0.80
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in mra13 Stripe Payments stripe-payments allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Stripe Payments: from n/a through <= 2.0.79.

NVD CVE-2023-48286Patchstack advisory

medium 5.4 CVE-2024-7353 · published 2024-08-07

Stored cross-site scripting (XSS) in Accept Stripe Payments (2.0.86 and older)

Affected
2.0.86 and older
Fixed in
2.0.87 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Accept Stripe Payments plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's accept_stripe_payment_ng shortcode in all versions up to, and including, 2.0.86 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-7353Wordfence advisorywordpress.orgportswigger.netPlugin source

medium 5.3 CVE-2023-48285 · published 2024-06-04

Cross-site scripting (XSS) in Accept Stripe Payments (2.0.79 and older)

Affected
2.0.79 and older
Fixed in
2.0.80
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Tips and Tricks HQ Stripe Payments allows Code Injection.This issue affects Stripe Payments: from n/a through 2.0.79.

NVD CVE-2023-48285Patchstack advisory

medium 4.8 CVE-2022-2194 · published 2022-07-17

Cross-site scripting (XSS) in Accept Stripe Payments (older than 2.0.64)

Affected
older than 2.0.64
Fixed in
2.0.64
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Accept Stripe Payments WordPress plugin before 2.0.64 does not sanitize and escape some of its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

NVD CVE-2022-2194WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Accept Stripe Payments vulnerability status badge
<a href="https://laskyr.com/plugins/stripe-payments"><img src="https://laskyr.com/plugins/stripe-payments/badge.svg" alt="Accept Stripe Payments vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit