Skip to content
Laskyr

Plugins · streamcast · data as of 2026-11-04

Is StreamCast safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.7)

As of 2026-11-04. 3 issues are on record for older versions; version 2.4.7 or newer fixes all of them that state a fix.

Latest version
2.4.7
Last updated
2026-10-27
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Embed a responsive live radio streaming player in WordPress – IceCast, Shoutcast, RadioCo, RadioJar & more via shortcode or Gutenberg block. — by bPlugins

What to do

  1. Update to the latest version (2.4.7). Anything older than 2.4.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get streamcast --field=version shows what you run; wp plugin update streamcast updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-116849 · published 2026-10-29

Stored cross-site scripting (XSS) in StreamCast (2.4.6 and older)

Affected
2.4.6 and older
Fixed in
2.4.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins StreamCast streamcast allows Stored XSS.This issue affects StreamCast: from n/a through 2.4.6.

NVD CVE-2026-116849Patchstack advisory

high 7.2 CVE-2026-62030 · published 2026-10-10

Server-side request forgery (SSRF) in StreamCast (2.4.5 and older)

Affected
2.4.5 and older
Fixed in
2.4.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Server Side Request Forgery (SSRF) in StreamCast <= 2.4.5 versions.

NVD CVE-2026-62030Patchstack advisory

medium 5.9 CVE-2024-43148 · published 2024-08-12

Stored cross-site scripting (XSS) in StreamCast (2.2.3 and older)

Affected
2.2.3 and older
Fixed in
2.2.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in bPlugins StreamCast allows Stored XSS.This issue affects StreamCast: from n/a through 2.2.3.

NVD CVE-2024-43148Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
StreamCast vulnerability status badge
<a href="https://laskyr.com/plugins/streamcast"><img src="https://laskyr.com/plugins/streamcast/badge.svg" alt="StreamCast vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit