Plugins · stream · data as of 2026-11-04
Is Stream safe? Known vulnerabilities and latest version
- Latest version
- 4.4.0
- Last updated
- 2026-08-31
- Active installs
- 70,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Real-time activity log and audit log for WordPress. Track every user action — logins, edits, plugin & settings changes — and get alerts. — by XWP
What to do
- Update to the latest version (4.4.0). Anything older than 4.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get stream --field=version shows what you run; wp plugin update stream updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-11907 · published 2026-08-07
Missing authorization check in Stream (4.2.0 and older)
- Affected
- 4.2.0 and older
- Fixed in
- 4.2.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Stream plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.2.0. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to access all Stream activity records via the Heartbeat API.
medium 5.5 CVE-2024-13879 · published 2025-02-17
Server-side request forgery (SSRF) in Stream (4.0.2 and older)
- Affected
- 4.0.2 and older
- Fixed in
- 4.1.0 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Stream plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 4.0.2 due to insufficient validation on the webhook feature. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services.
NVD CVE-2024-13879Wordfence advisoryCode change (fix)github.com
high 8.8 CVE-2024-7423 · published 2024-09-13
Cross-site request forgery (CSRF) in Stream (4.0.1 and older)
- Affected
- 4.0.1 and older
- Fixed in
- 4.0.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Stream plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.0.1. This is due to missing or incorrect nonce validation on the network_options_action() function. This makes it possible for unauthenticated attackers to update arbitrary options that can lead to DoS or privilege escalation via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2024-7423Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2022-43450 · published 2023-12-19
Missing authorization check in Stream (3.9.2 and older)
- Affected
- 3.9.2 and older
- Fixed in
- 3.9.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in XWP Stream.This issue affects Stream: from n/a through 3.9.2.
high 8.8 CVE-2022-43490 · published 2023-05-25
Cross-site request forgery (CSRF) in Stream (3.9.2 and older)
- Affected
- 3.9.2 and older
- Fixed in
- 3.9.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in XWP Stream plugin <= 3.9.2 versions.
medium 6.5 CVE-2022-4384 · published 2023-02-06
Information disclosure in Stream (older than 3.9.2)
- Affected
- older than 3.9.2
- Fixed in
- 3.9.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Stream WordPress plugin before 3.9.2 does not prevent users with little privileges on the site (like subscribers) from using its alert creation functionality, which may enable them to leak sensitive information.
high 8.8 CVE-2021-24772 · published 2021-11-17
SQL injection in Stream (older than 3.8.2)
- Affected
- older than 3.8.2
- Fixed in
- 3.8.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Stream WordPress plugin before 3.8.2 does not sanitise and validate the order GET parameter from the Stream Records admin dashboard before using it in a SQL statement, leading to an SQL injection issue.
Recent activity
- 2026-08-31 — latest release on wordpress.org (4.4.0).
- 2026-08-07 — Missing authorization check disclosed (CVE-2026-11907), fixed in 4.2.1.
- 2025-02-17 — Server-side request forgery (SSRF) disclosed (CVE-2024-13879), fixed in 4.1.0.
- 2024-09-13 — Cross-site request forgery (CSRF) disclosed (CVE-2024-7423), fixed in 4.0.2.
Get an email when Stream has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Stream (stream) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site request forgery (CSRF) (2) · Server-side request forgery (SSRF) (1) · Sensitive data exposure (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/stream (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/stream"><img src="https://laskyr.com/plugins/stream/badge.svg" alt="Stream vulnerability status"></a>