Plugins · strabl-a-checkout-solution · data as of 2026-11-04
Is STRABL safe? Known vulnerabilities and latest version
- Latest version
- 4.8.6
- Last updated
- 2026-10-07
- Active installs
- 10+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 8.0+
A supercharged Checkout & Payment provider for WooCommerce stores — by STRABL
What to do
- Update to the latest version (4.8.6). Anything older than 4.8.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get strabl-a-checkout-solution --field=version shows what you run; wp plugin update strabl-a-checkout-solution updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-3640 · published 2026-06-19
Missing authorization check in STRABL (4.5 and older)
- Affected
- 4.5 and older
- Fixed in
- 4.8.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The STRABL – A checkout solution plugin for WordPress is vulnerable to Missing Authentication in all versions up to and including 4.5. The plugin registers a REST API webhook endpoint at /wp-json/strabl/webhook/order with a permission_callback of __return_true, which allows all incoming requests without any authentication or authorization checks. No shared secret, signature validation, HMAC verification, or token-based authentication is implemented. This makes it possible for unauthenticated attackers to create fraudulent WooCommerce orders and mark them as completed by supplying paymentStatus=paid, manipulate existing order statuses by providing an externalOrderId, create new WordPress user accounts with the customer role, issue refunds on existing orders, cancel existing orders, and apply chargeback fees — all without making a legitimate payment or having any valid credentials.
NVD CVE-2026-3640Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-07 — latest release on wordpress.org (4.8.6).
- 2026-06-19 — Missing authorization check disclosed (CVE-2026-3640), fixed in 4.8.2.
Get an email when STRABL has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for STRABL (strabl-a-checkout-solution) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/strabl-a-checkout-solution (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/strabl-a-checkout-solution"><img src="https://laskyr.com/plugins/strabl-a-checkout-solution/badge.svg" alt="STRABL vulnerability status"></a>